Bug 336731 - fontconfig-devel.i386 conflicts with fontconfig-devel.x86_64
fontconfig-devel.i386 conflicts with fontconfig-devel.x86_64
Status: CLOSED DUPLICATE of bug 313011
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 17:13 EDT by Benjamin Smedberg
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 21:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benjamin Smedberg 2007-10-17 17:13:22 EDT
Description of problem:
The fontconfig-devel.i386 and fontconfig-devel.x86_64 packages cannot be
installed at the same time because they ship the arch-independent file
/usr/share/doc/fontconfig-devel-2.4.2/fontconfig-devel.txt

Version-Release number of selected component (if applicable):
FC7

How reproducible:
yum install fontconfig-devel.x86_64
yum install fontconfig-devel.i386

Actual results:
Transaction Check Error:
  file /usr/share/doc/fontconfig-devel-2.4.2/fontconfig-devel.txt from install
of fontconfig-devel-2.4.2-3.fc7 conflicts with file from package
fontconfig-devel-2.4.2-3.fc7
Comment 1 Nicolas Mailhot 2007-10-18 01:39:12 EDT
looks like more a tools problem than a package one
Comment 2 Benjamin Smedberg 2007-10-18 10:23:40 EDT
well... yum is doing the correct thing I think; the arch-specific packages
shouldn't have arch-indepent files in them
Comment 3 Behdad Esfahbod 2007-10-22 16:43:01 EDT
What's happening basically is that if two arch packages want to install the same
file, the files should be identical.  That works fine for doc files, except that
if they are generated as part of the build and have a timestamp or something you
are doomed... Fixed this in rhel4 and rhel5.  The fix is to not rebuild docs...
Comment 4 Behdad Esfahbod 2007-10-25 21:10:29 EDT

*** This bug has been marked as a duplicate of 313011 ***

Note You need to log in before you can comment on or make changes to this bug.