This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 336981 - Wireless device does not show up in Network Manager on Dell Inspiron 1520
Wireless device does not show up in Network Manager on Dell Inspiron 1520
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
http://www.linlap.com/wiki/Dell+Inspi...
:
Depends On:
Blocks: 328451
  Show dependency treegraph
 
Reported: 2007-10-17 22:43 EDT by Răzvan Sandu
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 17:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-10-17 22:43:01 EDT
Hello,

Description of problem:

The wireless device on the Dell Inspiron 1520 works (from the kernel point of
view) - please see bug #328451.

However, the wireless interface wlan0 doesn't show up in System ->
Administration -> Network, not even when the interface is up and actually
running. As a consequence, it cannot be controlled easily, set up for DHCP, etc.

It doesn't show up neither on the Hardware tab, nor on the Devices tab.

For wireless interface initialization, there is also a problem with
wpa_supplicant, which does not start at boot (it seem to report a missing file).


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.3.svn2970.fc8
wpa_supplicant-0.5.7-10.fc8


How reproducible:
Always.

Steps to Reproduce:
Please see bug #328451.
  
Actual results:
The wlan interface doesn't show up in NetworkManager.

Expected results:
The wlan interface should be present in NetworkManager and should be
configurable as any other network interface - start at boot, take IP address
through DHCP, etc.

Additional info:
http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132
http://forum.notebookreview.com/showthread.php?t=152717
http://www.linlap.com/wiki/Dell+Inspiron+1520
Comment 1 Dan Williams 2007-10-31 18:36:34 EDT
If this is still a problem, can you:

a) Update to latest rawhide kernels
b) Give the output of /usr/bin/nm-tool
c) Give the output of 'ls /sys/class/net'

THanks!
Comment 2 Răzvan Sandu 2007-11-01 13:39:17 EDT
Hello and thanks,

I've followed your instructions, here are the results:

1. Upgrade
kernel-2.6.23.1-42.fc8
NetworkManager-0.7.0-0.5.svn3030.fc8
wpa_supplicant-0.5.7-15.fc8

2. Output of /usr/bin/nm-tool

[root@mazarin ~]# nm-tool

NetworkManager Tool

State: connected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            b44
  Active:            yes
  HW Address:        00:1C:23:8F:4D:D7

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings

  IP Settings:
    IP Address:      192.168.1.69
    Subnet Mask:     255.255.255.0
    Broadcast:       192.168.1.255
    Gateway:         192.168.1.1
    DNS:             192.168.1.1
    DNS:             10.1.1.200
    DNS:             193.231.236.25


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 Wireless
  Driver:            b43-pci-bridge
  Active:            no
  HW Address:        00:1C:26:54:9E:86

  Capabilities:
    Supported:       yes

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

3. Output of 'ls /sys/class/net'

[root@mazarin ~]# ls /sys/class/net
eth0  lo  wlan0  wmaster0


NOTES:

a. NetworkManager, NetworkManagerDispatcher and wpa_supplicant services are
*stopped* by default (in ntsysv) after each package upgrade via yum. I've
started the three of them manually before running the above commands.

b. There is no trace of wlan0 in System -> Administration -> Network, neither on
the Hardware tab, nor on the Devices one.

c. There is no trace of wlan0 in the ifconfig output.

d. wpa_suplicant still reports a missing file at initialization (please see bug
#337001) and gives FAILED at system boot.

e. Hardware is an integrated Dell Wireless 1390 WLAN MiniCard on a (pretty
recent) Dell Inspiron 1520 - please see hardware details at links above.

Original Windows driver
http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R151520&SystemID=INS_PNT_PM_1520&servicetag=9BB153J&os=WLH&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=202821

Thanks A LOT,
Răzvan


Comment 3 Dan Williams 2007-11-01 15:33:50 EDT
Hmm, are you just typing 'ifconfig', or 'ifconfig -a'?  Just ifconfig won't show
the device unless it's up.

Also, this output shows that NetworkManager has found your device, but it won't
necessarily show up in System->Administration->Networking until you add it
manually to the profile there.

If you're happy with NetworkManager, you don't need to touch
System->Administration->Networking at all, you can just use NetworkManager.  If
you want to configure a static IP address or something, then you probably want
to turn of NM and use the Networking control panel exclusively.
Comment 4 Răzvan Sandu 2007-11-02 15:05:32 EDT
Hello,

Sorry, I think I did a huge mistake, believing that the application in System ->
Administration -> Network and NetworkManager are the same thing ! My fault !


In another location (with wireless coverage) but in the exact same conditions,
here's the output of ifconfig -a:

[root@mazarin ~]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1C:23:8F:4D:D7  
          inet addr:192.168.25.9  Bcast:192.168.25.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:23ff:fe8f:4dd7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10004 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6482 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14716133 (14.0 MiB)  TX bytes:542309 (529.5 KiB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5068 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5068 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:254224 (248.2 KiB)  TX bytes:254224 (248.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1C:26:54:9E:86  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr
00-1C-26-54-9E-86-00-00-00-00-00-00-00-00-00-00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

However, the main problem remains the same:

1. NetworkManager, NetworkManagerDispatcher and wpa_supplicant services are
started at boot (I've marked them in ntsysv - btw, how should the correct
default be in F8 ?)

2. There is no sign of wlan0 going up, neither at boot or when the laptop is
brought under wireless coverage. Wireless interface is activated by the hardware
point of view (activated by laptop's function buttons), but the LED showing
wireless connection is not lit.

3. There is no trace of wlan0 in System -> Administration -> Network, neither on
the Hardware tab, nor on the Devices one (how to activate it in profile if this
is not present on Hardware tab ?)

4. wpa_suplicant still reports a missing file at initialization (please see bug
#337001) and gives FAILED at system boot;

5. WAP is a DLink DWL-G700AP, configured for WPA2 authentication, with preshared
key.

6. when launched manually, wlassistant says:
[root@mazarin ~]# wlassistant
kbuildsycoca running...
DCOP Cleaning up dead connections.
Loaded application options.
All interfaces: eth0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
==>stderr: wlan0     Interface doesn't support scanning : Network is down

No networks found!
Application options saved.
Kernel socket closed.


Could you please give me any further directions ?

Thanks,
Răzvan
Comment 5 John W. Linville 2007-11-02 15:55:13 EDT
The scan is failing because the devices is down.  Normally NM would mark it 
up, so I'm not sure why it would be down.

   ifconfig wlan0 up

Do that before trying to scan.
Comment 6 Răzvan Sandu 2007-11-03 06:07:40 EDT
Hello,

After repeating the steps in comment #4 bug 328451 (I think I've messed
something experimenting with the drivers), the wireless LED is now lit up,
interface wlan0 now starts automatically at boot.

(Could you *please* include the drivers suggested at comment #4 bug 328451 in
default kernel of F8 ?   ;-) )

Now: 

[root@mazarin ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1C:23:8F:4D:D7  
          inet addr:192.168.25.9  Bcast:192.168.25.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:23ff:fe8f:4dd7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1123 errors:0 dropped:0 overruns:0 frame:0
          TX packets:825 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1669590 (1.5 MiB)  TX bytes:68092 (66.4 KiB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:19252 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19252 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:962760 (940.1 KiB)  TX bytes:962760 (940.1 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1C:26:54:9E:86  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr
00-1C-26-54-9E-86-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)



The problem still remains, because:

1. No trace of wlan0 in System -> Administration -> Network (cannot control the
interface in an easy way).

2. Don't get address by DHCP.

3. wpa_supplicant reports FAIL, in red, during system initialization; however,
doing manually a "service wpa_supplicant restart", *afterwards*, shows two OKs
in green.

4. Manually launching wlassistant for the first time shows the (unique) wireless
network, with full radio strenghth, channel 6. I select DHCP as a method to get
IP address. Then:

WPA version: WPA2
Group cipher: CCMP
Pair cipher: CCMP
Authentication suite: PSK

WPA key: - I enter the correct preshared key

There is an "ASCII" check box nearby, checked.

Wizard reports succesful connection.


However, in the background terminal where I launched wlassistant I get the same
error message:

[root@mazarin ~]# wlassistant
kbuildsycoca running...
Reusing existing ksycoca
Loaded application options.
All interfaces: eth0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
No DHCP client running.
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig wlan0 mode managed channel 6 key off essid zando
iwconfig_ap: /sbin/iwconfig wlan0 ap 00:19:5B:0E:A6:27
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
CONNECTION FAILED.
disconnect: /sbin/iwconfig wlan0 mode managed key off ap off essid off
Application options saved.
Kernel socket closed.

DHCP client *is* installed (I get DHCP addreses on the wired network). DHCP
server *is* functional (I get correct DHCP addreses on other wireless devices in
the same area).

Still no IP address for wlan0 after all this, no matter how long I'll wait.

Please note that the MAC address reported by wlassistant (00:19:5B:0E:A6:27) is
different of that of wlan0 (00:1C:26:54:9E:86).


Any further idea, please ?


Regards,
Răzvan
Comment 7 John W. Linville 2007-11-04 14:52:18 EST
The b43 driver _is_ included in the F8 kernel.  The firmware can not be 
included in Fedora because we have no legal basis for doing so.
Comment 8 Răzvan Sandu 2007-11-09 16:59:05 EST
Hello,

Now that the final version of F8 is released, I've done a fresh install of it
and reinstalled the firmware, exactly as John instructed me in comment #4.

The problem remains, since:

1. wlan0 is not up at boot;
2. wlan0 doesn't appear in system-config-network, on the Hardware tab, so I
cannot configure it on Device tab and cannot control the interface.
3. Even if I start wlan0 mannually and have an active DHCP server in my network,
the wlan0 interface does not take an IP address.

I will close this bug for now and reenter the above as a separate bug on the
"system-config-network" component.


Many thanks,
Razvan

Note You need to log in before you can comment on or make changes to this bug.