Bug 337451 - rpcbind init script has wrong logic in start function
rpcbind init script has wrong logic in start function
Status: CLOSED DUPLICATE of bug 335141
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 05:12 EDT by Joe Wrigley
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 09:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Wrigley 2007-10-18 05:12:56 EDT
Description of problem:
Starting (or restarting of rpcbind) fails. As far as I can see, it is due to the
logic being applied by this line:

        # Check that networking is up.
        [ "$NETWORKING" = "no" ] || exit 6

This looks like the inverse of what the comment says it is doing and replacing
"no" with "yes" fixes the problem. (Setting NETWORKING=no in
/etc/sysconfig/network has the same effect, but then nfs does not start as you
would expect)


Version-Release number of selected component (if applicable):
rpcbind-0.1.4-9.fc8

How reproducible:
Reproducible

Steps to Reproduce:
1. Set NETWORKING=yes in /etc/sysconfig/network
2. Issue service rpcbind start or restart
3. See it fail
Comment 1 Terje Røsten 2007-10-19 16:22:11 EDT
>         # Check that networking is up.
>         [ "$NETWORKING" = "no" ] || exit 6
> 
> This looks like the inverse of what the comment says it is doing and replacing
> "no" with "yes" fixes the problem. 

Yes, I fixed ut by changing to 
        
           [ "$NETWORKING" = "no" ] && exit 6

To me the maintainer seems to be in a hurry, it's soon time for RHEL5.1 and F-7
I guess...

BTW: this is dup of #335141 .
Comment 2 Steve Dickson 2007-10-23 09:30:43 EDT
Fixed in rpcbind-0.1.4-10.fc8

*** This bug has been marked as a duplicate of 335141 ***

Note You need to log in before you can comment on or make changes to this bug.