Bug 33768 - up2date hangs at 2% and produces python error
up2date hangs at 2% and produces python error
Status: CLOSED DUPLICATE of bug 18994
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-29 02:15 EST by Need Real Name
Modified: 2016-09-29 14:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 11:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44061 master NEW virt: enable glusterfs access through libgfapi interface 2016-09-29 14:42 EDT

  None (edit)
Description Need Real Name 2001-03-29 02:15:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


While trying to run up2date, a dialog window appears then hangs.  The
following is part of the error message.  The full test is in the additional
info section:
[root@dizzy /root]# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 164, in onStartPageNext
    (self.pkgList, self.skipPkgList) =
up2date.getUpdatedPackageList(pwin.setLabel, pwin.setProgress)
 


Reproducible: Always
Steps to Reproduce:
1. Open Terminal Window
2.  Type up2date
3.
	

Actual Results:  Dialog window hangs at 2%.  

Expected Results:  up2date should show files to be updated.

I did check to make sure the correct version of python was installed:  It
is 
python-1.5.2-27. 

[root@dizzy /root]# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 164, in onStartPageNext
    (self.pkgList, self.skipPkgList) =
up2date.getUpdatedPackageList(pwin.setLabel, pwin.setProgress)
  File "/usr/share/rhn/up2date/up2date.py", line 894, in
getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 851, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 770, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
TypeError: too many arguments; expected 2, got 3
[root@dizzy /root]# cat /etc/redhat-release 
Red Hat Linux release 7.0 (Guinness)
[root@dizzy /root]# uname -m
i686
[root@dizzy /root]#
Comment 1 Bill Crawford 2001-03-30 11:06:10 EST
I have same symptoms but a slightly different traceback.  Is it worth opening a
separate bug?

[root@fraser RPMS]# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 240, in onStartPageNext
    up2date.maybeUpdateVersion()
  File "/usr/share/rhn/up2date/up2date.py", line 374, in maybeUpdateVersion
    idVer = xmlrpclib.loads(getSystemId())[0][0]['os_release']
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 509, in loads
    p.feed(data)
TypeError: argument 1: expected read-only character buffer, None found
Comment 2 Preston Brown 2001-03-30 22:14:19 EST
To the first poster:  This is a known bug, to be fixed in a forthcoming errata version.  Until then, you 
can get around the bug by turning off the option to "retrieve all packages" or by not using the "-a" 
command line option.

To the second user: you are using  a beta version of up2date on 7.0 (or on Fisher/Wolverine).  This 
problem is only in the beta version, and has been corrected internally.


*** This bug has been marked as a duplicate of 18994 ***

Note You need to log in before you can comment on or make changes to this bug.