Bug 337851 - Rhythmbox does not ship with MTP and generic player plugin
Summary: Rhythmbox does not ship with MTP and generic player plugin
Status: CLOSED DUPLICATE of bug 264541
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-18 12:26 UTC by Martin Jürgens
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-10-18 12:46:50 UTC


Attachments (Terms of Use)

Description Martin Jürgens 2007-10-18 12:26:57 UTC
Description of problem:
Just tried f8t3 and I noticed that Rhythmbox does not ship with the mtpdevice
and the generic-player plugins although they are included in the
rhythmbox-0.11.2 tarball.

It would definitely be cool to have that in Fedora 8, as I own a MTP player
which I could fill with music easily then. Also, friends own "generic" players,
which could be filled easily then, too.

Rhythmbox could ship with those plugins being disabled by default.

Version-Release number of selected component (if applicable):
0.11.2-6

Comment 1 Bastien Nocera 2007-10-18 12:46:50 UTC
The generic player plugin is there:
$ rpm -q rhythmbox
rhythmbox-0.11.2-9.fc8
$ rpm -ql rhythmbox | grep generic
/usr/lib64/rhythmbox/plugins/generic-player
/usr/lib64/rhythmbox/plugins/generic-player/generic-player-ui.xml
/usr/lib64/rhythmbox/plugins/generic-player/generic-player.rb-plugin
/usr/lib64/rhythmbox/plugins/generic-player/libgeneric-player.so

You won't see it in the plugins list though, as it's a builtin plugin. As for
the MTP plugin, it's too buggy and crashy for now, but it's included in the
Fedora 9 builds. It might make it in an F8 update if the crashers get fixed.

See http://koji.fedoraproject.org/koji/buildinfo?buildID=20726

*** This bug has been marked as a duplicate of 264541 ***


Note You need to log in before you can comment on or make changes to this bug.