Bug 33848 - Installer exit abnormally after loading the packages: signal 9
Installer exit abnormally after loading the packages: signal 9
Status: CLOSED DUPLICATE of bug 33488
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-29 09:09 EST by Simone Mancino
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-29 11:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simone Mancino 2001-03-29 09:09:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


I'm installing RedHat on my netfinity server.
I selected "Everythings" at the packages installaztion option. Then the 
anaconda program start and my installation steps beginning;
I inserted the 2nd CD when it requested me.
At the end of package's copy operation, It return me an error exception, 
and i dump it:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in 
doInstall
    self.copyExtraModules()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in 
copyExtraModules
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/ips.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/ips
names:  ips.o ips.o
command: cd /mnt/sysimage/lib/modules; gunzip 
< /tmp/modules/ips/modules.cgz | /mnt/sysimage/bin/cpio  --quiet -iumd  
2.2.16-22smp/ips.o 2.2.16-22/ips.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/ips.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 8273670>
pattern:  2.2.16-22smp/ips.o 2.2.16-22/ips.o
name: ips

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hda'
sS'progressWindow'
p9

<failed>


Reproducible: Always
Steps to Reproduce:
1. Install redhat 7 on netfinity 5100
2. My system have 2 CPUs
3. Select "EVERYTHINGS" at the package selection

	

Actual Results:  Installation exit abnormally. Server never starts
Comment 1 Michael Fulbright 2001-03-29 11:32:22 EST
Matt what would cause this to fail?
Comment 2 Matt Wilson 2001-03-29 11:39:09 EST
looks like a driver disk is in use.  I have a dup of this around here somewhere.
Comment 3 Matt Wilson 2001-03-29 11:41:21 EST

*** This bug has been marked as a duplicate of 33488 ***

Note You need to log in before you can comment on or make changes to this bug.