Bug 3413 - bind core dumps on 386 processor
bind core dumps on 386 processor
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 3418 3419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-12 06:36 EDT by skeeter
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-19 18:01:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description skeeter 1999-06-12 06:36:14 EDT
Performed install on 386 system.  Went to run bind and
received core dump.  Took SRPM and recompiled on 386 and
everything worked fine.

Personal guess is maybe the RPM was compiled for something
higher (eg. 586 or 686 processor).
Comment 1 Alan Cox 1999-06-12 17:35:59 EDT
objdump --disassemble shows that it contains bswap instructions. It
has been linked with some kernel headers in error in the RPM.

Check the includes it is sucking in.

Alan
Comment 2 Bill Nottingham 1999-06-14 13:02:59 EDT
*** Bug 3418 has been marked as a duplicate of this bug. ***

After uprgrading an old 386 system to RH 6.0 dip
appears to work correctly but the modem hangs up after
establishing the connection (dip terminates).

After rebuilding the SRPM on a stock RH 6.0 system dip works
again. My guess is that it has been compiled with some
optimizations turned on (586 and higher).
See also bug 3413(bind) (which was the same here) and
ipchains.

------- Additional Comments From alan@redhat.com  06/12/99 20:36 -------
Another bswap case. Might be worth us running objdump scns across
everything to be sure we get the lot

Alan

------- Additional Comments From   06/14/99 14:53 -------
None of the bind, dip, ipchains RPMs build on my RH6.0 system with
-m486 (The only thing I changed on the system I build the working RPMs
on is a newer kernel 2.2.9). I don't think -m486 is related.
I'd also recommend the scan Alan suggested since especialy the dip
problem wasn't easy to identify and I guess there are some more
packages affected.*** Bug 3419 has been marked as a duplicate of this bug. ***

ipchains crashes on 386 systems.

Rebuilding the SRPM fixes the problem. So I think it's the
same as with bind and dip (compiled with pentium
optimizations).

------- Additional Comments From alan@redhat.com  06/12/99 20:33 -------
Another package built with a kernel header using bswap. Looks like
ntohs/ntohl are the culpritsI believe it's a problem with the default RPM optflags,
which include -m486...
Comment 3 x 1999-06-14 14:54:59 EDT
None of the bind, dip, ipchains RPMs build on my RH6.0 system with
-m486 (The only thing I changed on the system I build the working RPMs
on is a newer kernel 2.2.9). I don't think -m486 is related.
I'd also recommend the scan Alan suggested since especialy the dip
problem wasn't easy to identify and I guess there are some more
packages affected.
Comment 4 Jeff Johnson 1999-06-25 08:10:59 EDT
I've hacked out -m486 in bind-8.2.1-1.
Comment 5 Bill Nottingham 1999-08-19 18:01:59 EDT
It should be fixed with the latest Raw Hide build; plus the compiler
should be fixed with the latest egcs in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.