Bug 341731 - multiarch conflicts in kdebluetooth
multiarch conflicts in kdebluetooth
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebluetooth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 17:42 EDT by Bill Nottingham
Modified: 2014-03-16 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0-0.37.beta8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 13:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-19 17:42:33 EDT
kdebluetooth (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/applications/kde/kbtobexsrv.desktop from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/ca/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/da/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/en/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/es/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/et/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/fr/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/it/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/nl/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/pt/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/ru/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/doc/HTML/sv/kdebluetooth/index.cache.bz2 from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8
  file /usr/share/services/kbluetooth_kbtobexsrv.desktop from install of kdebluetooth-1.0-0.34.beta8.fc8 conflicts with file from package kdebluetooth-1.0-0.34.beta8.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.
Comment 1 Gilboa Davara 2007-10-27 04:08:20 EDT
OK.
I'll create a new package called kdebluetooth-doc and push all the offending
files into it.

- Gilboa
Comment 2 Ville Skyttä 2007-10-27 12:53:03 EDT
I don't think that's a good idea, aren't those help files?  Better would be to
split libraries into a -libs subpackage.
Comment 3 Gilboa Davara 2007-10-27 13:16:02 EDT
I don't like the -libs idea.
The libs themselves are pretty useless (without the binaries).
Creating a separate -lib package just to satisfy multi-arch is... troubling...?

- Gilboa
Comment 4 Gilboa Davara 2007-10-27 13:16:44 EDT
(Though it is very much possible that I didn't really understand the source of
the problem... do I?)
Comment 5 Gilboa Davara 2007-10-27 13:20:52 EDT
... Come to think about it... how the hell can a text file -
/usr/share/services/kbluetooth_kbtobexsrv.desktop that has no time-stamp in-it
create a collision between x86_64 and i386?
Ville, do you have a devel machine at your disposal? Can you please check it?
(My rawhide machine is down due to some weird-combo-bug between F8 and vmware)

- Gilboa
Comment 6 Ville Skyttä 2007-10-28 05:10:46 EDT
Splitting out -libs to avoid multiarch problems is how the vast majority of
packages get treated, and people are getting accustomed to that.  On the other
hand, having to install help files separately is highly unusual.

No need for a devel box to see the kbluetooth_kbtobexsrv.desktop conflict:

$ rpmdev-diff kdebluetooth-1.0-0.34.beta8.fc8.i386.rpm
kdebluetooth-1.0-0.34.beta8.fc8.x86_64.rpm
[...]
-Exec=/usr/lib/kdebluetooth/servers/kbtobexsrv
+Exec=/usr/lib64/kdebluetooth/servers/kbtobexsrv

Installing to /usr/libexec/kdebluetooth/servers would be one way to fix that,
but if a -libs subpackage will be created, there's no need to do anything about
this.
Comment 7 Gilboa Davara 2007-10-28 05:20:05 EDT
OK. I get the picture; can't say the I like it, but in Rome...

I assume that the desktop files should be added to -libs package?

- Gilboa
Comment 8 Ville Skyttä 2007-10-28 06:13:36 EDT
No, just the %{_libdir}/lib* stuff, nothing more (although I'm not 100% sure
about %{_libdir}/kde3/*).  -devel should possibly be changed to require -libs
instead of the main package, and an Obsoletes added to -libs as explained here:
https://www.redhat.com/archives/fedora-devel-list/2007-October/msg02171.html

Various kde* packages in CVS's devel branch have already split out -libs and can
be used as examples.

FWIW, I don't really like it either.
Comment 9 Gilboa Davara 2007-11-07 00:44:58 EST
Ville,

Does it seems OK to you?
SPEC: http://gilboadavara.thecodergeek.com/kdebluetooth.spec

- Gilboa
Comment 10 Ville Skyttä 2007-11-07 14:13:35 EST
* -libs requires itself, that dep should probably be just removed
* %defattr missing from %files libs
* I would make -libs Group System Environment/Libraries, not Development/Libraries
* %changelog should probably say "Fix multilib conflicts" (and a reference to
this bug added) instead of just "Fix multilib"

Other than those, on a cursory look, seems ok to me.
Comment 11 Gilboa Davara 2007-11-08 01:59:10 EST
OK. Fixed SPEC.
SPEC: http://gilboadavara.thecodergeek.com/kdebluetooth.spec

Closed, sending out a new build.
Comment 12 Fedora Update System 2007-11-14 22:37:33 EST
kdebluetooth-1.0-0.37.beta8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebluetooth'
Comment 13 Fedora Update System 2007-11-14 22:40:48 EST
kdebluetooth-1.0-0.37.beta8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebluetooth'
Comment 14 Fedora Update System 2007-11-20 13:09:30 EST
kdebluetooth-1.0-0.37.beta8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2007-11-20 13:10:06 EST
kdebluetooth-1.0-0.37.beta8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.