Bug 34376 - Savage IX broke in QA0401
Savage IX broke in QA0401
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 35553 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-02 16:31 EDT by Lamar Owen
Modified: 2007-03-26 23:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 14:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 config for Toshiba 2800 Savage IX/MV (14.61 KB, text/plain)
2001-04-05 10:52 EDT, Lamar Owen
no flags Details
X server log for Toshiba 2800 Xavage IX/MV (23.11 KB, text/plain)
2001-04-05 10:53 EDT, Lamar Owen
no flags Details

  None (edit)
Description Lamar Owen 2001-04-02 16:31:03 EDT
QA0327 liked the Savage IX in this Toshiba 2800.  QA0401's XFree86 does 
not, producing objectionable 'snow' on the screen.

The Framebuffer server used by anaconda didn't do this on QA0401 either.
Comment 1 Preston Brown 2001-04-03 15:33:03 EDT
Nothing changed for the savage driver between the 27th and the 1st.
Comment 2 Lamar Owen 2001-04-03 15:52:42 EDT
Ok, I'm checking something here.....

QA0401 has 4.0.3-5 XFree86.  Checking its Changelog, I see written for the 27th:
* Tue Mar 27 2001 Mike A. Harris <mharris@redhat.com>

- Updated Savage driver dropin to version 1.15, fixes xdm/kdm crashes,
  added XFree86-4.0.3-savage-glitch.patch

QA0327 has 4.0.3-3 XFree86. Checking its Changelog, and I don't see any of -5's Changelog entries post-3/23 (There are two of them,not counting the 
savage patch above:

* Mon Mar 26 2001 Mike A. Harris <mharris@redhat.com>

- Various Xaw fixes from <jik@kamens.brookline.ma.us> including:
  (#31618 - XFree86-4.0.3-xaw-freed-mem-deref.patch),
  (#33152 - XFree86-4.0.3-xaw-readtext.patch),
  (#31540 - XFree86-4.0.3-xaw-flashing-paren.patch)

* Sun Mar 25 2001 Mike A. Harris <mharris@redhat.com>

- Added XFree86-4.0.3-pagesize-fixup.patch to fix bad page size assumptions
  in DRI code.  Based on head branch patch received from notting@redhat.com
  Applied only to non x86 platforms.


In particular, 4.0.3-3 XFree86 doesn't have the afforementioned savage-glitch.patch. So the savage driver changed between QA0327 and QA0401, even if 
no changes happened between 3/27 and 4/01 :-)
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11
Comment 3 Mike A. Harris 2001-04-05 03:21:46 EDT
Yes, you are correct.  The Savage driver was updated.  Preston must have
missed that.  ;o)  The current driver fixes numerous problems that have
been reported in the Savage driver.  We think although the current driver
may still contain bugs (I'm sure it does), it is less buggy for more people.

The framebuffer server used by anaconda is XFree86 3.3.6, and it hasn't
changed, so that is why it works in anaconda.  If the 4.0.3 server does not
work for you, please try using 3.3.6 instead.  I'll look into this problem
with the driver author, however in order to do so, I need your config file
and a copy of your X server logs.  Please attach using the link below.
Comment 4 Lamar Owen 2001-04-05 10:52:17 EDT
Created attachment 14729 [details]
XFree86 config for Toshiba 2800 Savage IX/MV
Comment 5 Lamar Owen 2001-04-05 10:53:33 EDT
Created attachment 14730 [details]
X server log for Toshiba 2800 Xavage IX/MV
Comment 6 Lamar Owen 2001-04-05 10:55:39 EDT
I'm going to try other color depths and resolutions to see if there are any 
changes.
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11
Comment 7 Lamar Owen 2001-04-05 11:04:53 EDT
Color depth of 16bpp doesn't snow; 24bpp does.

So I'll be using 16bpp until you need me to test a driver.
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11
Comment 8 hjl 2001-04-11 14:28:20 EDT
*** Bug 35553 has been marked as a duplicate of this bug. ***
Comment 9 hjl 2001-04-11 14:28:44 EDT
*** Bug 35553 has been marked as a duplicate of this bug. ***
Comment 10 hjl 2001-04-11 14:30:42 EDT
Using 16pp or backout XFree86-4.0.3-savage-glitch.patch
fixes the problem for me.
Comment 11 Mike A. Harris 2001-04-13 10:54:41 EDT
Ok, thanks H.J.  I've killed that patch.  This will appear in the -9
rawhide release shortly.  ftp://people.redhat.com/mharris

If anyone experiences this problem still after -9, please reopen.

Note You need to log in before you can comment on or make changes to this bug.