Bug 343841 - hplip doesn't see gzipped HP-Fax-hplip PPD file
hplip doesn't see gzipped HP-Fax-hplip PPD file
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: 467534 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-10-20 10:27 EDT by Malcolm Amir Hussain-Gambles
Modified: 2009-07-14 14:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 14:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Malcolm Amir Hussain-Gambles 2007-10-20 10:27:12 EDT
Description of problem:

hplip doesn't contain any .ppd files that come with hplip all missing!
So theere are no drivers

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install hplip
2. doesn't print! no drivers to configure it!
Actual results:
no printing

Expected results:

Additional info:

Downloading the hplip from sourceforge and copying the ppd files into
/usr/share/ppd/ solves the problem and it all prints fine
Comment 1 Tim Waugh 2007-10-22 11:36:09 EDT
As I understand it, all of the PPDs shipped with HPLIP are generated from foomatic.

Which printer are you trying to configure, and how are you going about
configuring it?
Comment 2 Malcolm Amir Hussain-Gambles 2007-11-02 17:01:35 EDT
Installed on my desktop, the actual problem is that when you use the hp gui, at
the end it says that the driver doesn't exist for the above reason.
However if you ignore the error, it works just fine. So it appears to be an
issue with the gui looking in /usr/share/ppd/
Comment 3 Malcolm Amir Hussain-Gambles 2007-11-02 17:09:10 EDT
I am using hp-setup to configure the printer by the way, and it is a networked 
HP C6180 "all in one"
Comment 4 Tim Waugh 2007-11-13 10:35:03 EST
What does the error message say, precisely?
Comment 5 Robert Petranović 2008-04-01 10:35:21 EDT
I've had the same error too. 

First hp-toolbox says that there is no sudo/su utility to run the setup. After
runing hp-setup as super user, I was going to install my device, and at the end,
the error box appeared saying it can't find the HP fax ppd file (HP-Fax-hplip.ppd). 

I searched into the /usr/share/foomatic/db/source/PPD/HP folder and locate
HP-Fax-hplip2.ppd and HP-Fax-hplip.ppd.gz. First I've tried to rename the
HP-Fax-hplip2.ppd to HP-Fax-hplip.ppd. Then the setup has found the file saying
it's wrong: it's driver for HP-fax2 device and that it's searching for HP-fax....

Then I've simply unpacked the HP-Fax-hplip.ppd.gz and everything worked fine...
(except the sudo thing).

BTW, I'm using HP Photosmart 3310
Comment 6 Bug Zapper 2008-05-13 23:41:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 7 Tim Waugh 2008-10-21 09:21:13 EDT
*** Bug 467534 has been marked as a duplicate of this bug. ***
Comment 8 Bug Zapper 2009-06-09 19:05:48 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 9 Bug Zapper 2009-07-14 14:24:18 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.