Bug 343991 - Will not download updates
Will not download updates
Status: CLOSED DUPLICATE of bug 321251
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-20 14:16 EDT by John O Richardson Jr
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-22 14:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John O Richardson Jr 2007-10-20 14:16:41 EDT
Description of problem:Component: pirut
Summary: TBee905ca7 __init__.py:166:pirutCDHandler:NameError: global name
'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
  File "/usr/sbin/pup", line 610, in main
  File "/usr/sbin/pup", line 449, in run
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 166, in
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at
0xa3b19ec> :1.4 /org/freedesktop/Hal/Manager at 0xa408b6c> implementing
'org.freedesktop.Hal.Manager' at 0xa408acc>
name: Fedora 7.92
self: <__main__.PackageUpdater object at 0xa1db4ac>
args: ()
umount: False
mediaid: 1191241688.811639
HalCD: <module 'pirut.HalCD' from
dev: <pirut.HalCD.HALBlockDevice instance at 0xa40878c>
discnum: 1
kwargs: {'mediaid': '1191241688.811639', 'name': 'Fedora 7.92', 'url': None,
'text': <yum.yumRepo.YumRepository object at 0xa3c1eec>, 'relative':
'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method
YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0xa3c1eec>>,
(), {}), 'copy_local': 1, 'discnum': 1, 'local':
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_DVD__RW_DVD8701

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:Not sure which platform.  I'm not an expert.
Comment 1 John O Richardson Jr 2007-10-20 14:19:10 EDT
OS is being used on VMware Player
Comment 2 Jeremy Katz 2007-10-22 14:09:43 EDT

*** This bug has been marked as a duplicate of 321251 ***

Note You need to log in before you can comment on or make changes to this bug.