This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 344761 - Anaconda fails to make grub menu for Windows
Anaconda fails to make grub menu for Windows
Status: CLOSED DUPLICATE of bug 322401
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 20:26 EDT by John Summerfield
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 21:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2007-10-21 20:26:05 EDT
Description of problem:
Even though I installed to a system with running Windows XP, afterwards I am not
able to boot Windows from the menu,

Version-Release number of selected component (if applicable):


How reproducible:
1/1

Steps to Reproduce:
1. 1. Install Windows (I have an HP DC7000p SFF with Windows preinstalled. See
below)
2. Install F8Test3. I did so from DVD
3. 
  
Actual results:

Grub's menu had one entry: for Fedora.

Expected results:
One, preferably two, entries for Windows and one for Fedora.

Additional info:
Here is my partition table after the install:
[root@potoroo ~]# fdisk -l /dev/sda

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd42ad42a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        8669    69633711    7  HPFS/NTFS
/dev/sda2            8671        9715     8393962+   7  HPFS/NTFS
/dev/sda3            9716        9728      104422+  72  Unknown
/dev/sda4            9729       38913   234428512+   5  Extended
/dev/sda5            9729        9741      104391   83  Linux
/dev/sda6            9742       38913   234324058+  8e  Linux LVM
[root@potoroo ~]# 

Before the install, the first three entries existed. They were created by
copying (with dd) the original, 80 Gb, drive.
sda1 is the Windows system.
sda2 is the recovery partition. I have not perused its contents, but I expect
it's a bootable Windows system.

Here is the relevant line from the ks file that Anaconda created:
bootloader --location=mbr --driveorder=sda --append="pci=nomsi,nommconf rhgb quiet"

Here is the grub menu. I have changed the timeout, 5s is too short, and removed
"hiddenmenu" - IMV hiding the menu is stupid.

[root@potoroo ~]# cat /boot/grub/menu.lst  | grep -v ^#
default=0
timeout=15
splashimage=(hd0,4)/grub/splash.xpm.gz
title Fedora (2.6.23.1-23.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-23.fc8 ro root=/dev/VolGroup00/LogVol00
pci=nomsi,nommconf vga=794
        initrd /initrd-2.6.23.1-23.fc8.img
title Fedora (2.6.23-0.214.rc8.git2.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23-0.214.rc8.git2.fc8 ro
root=/dev/VolGroup00/LogVol00 pci=nomsi,nommconf vga=794
        initrd /initrd-2.6.23-0.214.rc8.git2.fc8.img
[root@potoroo ~]#
Comment 1 Jeremy Katz 2007-10-21 21:02:29 EDT

*** This bug has been marked as a duplicate of 322401 ***

Note You need to log in before you can comment on or make changes to this bug.