Bug 34494 - Network hangs without error messages
Network hangs without error messages
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 10:01 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:31:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-03 10:01:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; I)


I'm using the the 2.2.16-35 smp kernel and a 3c905 netcard.The network hangs after a varying time without error messages (very similar to 
bug 
22717and bug 22583). The way to get it back working is to stop the network unload the netcard module, load it again and restart the network. 
The time until the network hangs seems to depend on how much you use the network. Usage seems to prolong the time and vice versa. I 
don't 
think it has to do with auto-cleaned modules though, but rather a kernel/driver problem. I get the same problem when I load the modules by 
hand without the "auto clean" flag set. Removing the kmod script does not change the situation either. Also, when the network is hanging, 
lsmod still reports the netcard module as loaded and used. The problems still needs a solution though, since the networks always hangs after 
1-3 days (depending on usage) of uptime on all my RedHat 7.0 machines. I would be greatful for hints on solution. The ping trick (every 5 
minutes) doesn't work for me. The same hw-components and configuration worked well before upgrading to the current kernel.

Reproducible: Always
Steps to Reproduce:
1. boot the machine
2. wait 1-3 days
3. it seems to happen faster with less network usage
	

Actual Results:  The machine is unreachable from the network (even with ping) the network is also unreachable from the machine. Also the 
netstat -r shows no route via eth0. Just restarting or reloading the network doesn't help.

Expected Results:  as above

I also upgraded glibc to version 2.2-12 and xinetd to version 2.1.8.9pre11-1 when I upgraded the kernel. The change of xinetd seems unlikely 
to 
have anything to do with the problem, but upgrading glibc might well have some implication
Comment 1 Alan Cox 2003-06-09 11:31:48 EDT
This should be long fixed. If not then feel free to reopen it against the
current errata kernel

Note You need to log in before you can comment on or make changes to this bug.