Bug 345461 - pulseaudio plugin for xine does not work well with audio streams (amarok)
pulseaudio plugin for xine does not work well with audio streams (amarok)
Status: CLOSED DUPLICATE of bug 439731
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-22 12:14 EDT by Julian Sikorski
Modified: 2008-04-07 14:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 14:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-22 12:14:07 EDT
Description of problem:
Today I tried to play some audio streams using amarok. I figured out that they
do not work at all when using pulseaudio. Here is the relevant portion of
pulseaudio -v output:

I: client.c: Created 11 "Native client (UNIX socket client)"
I: protocol-native.c: Got credentials: uid=500 gid=500 success=1
I: protocol-native.c: Enabled SHM for new connection
I: client.c: Client 11 changed name from "Native client (UNIX socket client)" to
"amarokapp"
I: module-volume-restore.c: Restoring volume for
<pulsecore/protocol-native.c$amarokapp>
I: module-volume-restore.c: Restoring sink for
<pulsecore/protocol-native.c$amarokapp>
I: resampler.c: Using resampler 'speex-float-0'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 0.
I: sink-input.c: Created input 5 "audio stream" on
alsa_output.pci_8086_27d8_alsa_playback_0 with sample spec s16le 2ch 44100Hz
I: module-alsa-sink.c: Trying resume...
I: module-alsa-sink.c: Resumed successfully...
I: module-alsa-sink.c: Starting playback.
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_27d8_alsa_playback_0 idle
for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-alsa-sink.c: Trying resume...
I: module-alsa-sink.c: Resumed successfully...
I: module-alsa-sink.c: Starting playback.
I: sink-input.c: Freeing output 5 "audio stream"
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_27d8_alsa_playback_0 idle
for too long, suspending ...
I: module-alsa-sink.c: Device suspended...

My wild guess is that PA is not giving amarok enough time to buffer the stream
and start playing it.

Version-Release number of selected component (if applicable):
xine-lib-extras-1.1.8-4.fc8.x86_64
pulseaudio-0.9.7-0.16.svn20071017.fc8.x86_64

How reproducible:
always

Steps to Reproduce:
1. start amarok
2. set it to use xine and pulseaudio
3. browse the streams list in  the sidebar
4. try to play one
  
Actual results:
xine message about busy device and no sound

Expected results:
guess what ;)

Additional info:
You might need to press play several times, but this is unrelated.
Comment 1 Julian Sikorski 2007-10-22 12:21:58 EDT
For reference, totem using xine backend and pulseaudio output plugin seems to
work fine, to this looks like an issue with amarok to me. Reassigning.

Version-Release number of selected component (if applicable):
amarok-1.4.7-7.fc8.x86_64
Comment 2 Julian Sikorski 2007-11-15 14:49:26 EST
Any updates on this? Having to restart amarok a few times to get the stream
playing is quite annoying to say at least.
Comment 3 Julian Sikorski 2007-11-17 15:27:48 EST
That's what amarok shows when it fails:
Sound output is unavailable. Device is busy.
xine parameters:
Comment 4 Marek Zukal 2008-01-06 16:04:09 EST
This also happens when you press an arrow key few times to change position in song
Comment 5 Rex Dieter 2008-02-21 00:07:08 EST
This is more a xine-lib issue, re-assigning.
Comment 6 Lubomir Kundrak 2008-03-31 06:49:14 EDT
I wonder if patch in bug #439731 would be of help here. I can't tell though,
given I don't use xine, nor amarok.
Comment 7 Rex Dieter 2008-03-31 07:36:04 EDT
Almost certainly would help.
Comment 8 Rex Dieter 2008-04-07 14:00:43 EDT

*** This bug has been marked as a duplicate of 439731 ***

Note You need to log in before you can comment on or make changes to this bug.