Bug 439731 - [PATCH] Please update PulseAudio plugin
[PATCH] Please update PulseAudio plugin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 345461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 22:05 EDT by Lennart Poettering
Modified: 2008-04-07 16:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.1.11.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 09:08:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2008-03-30 22:05:26 EDT
The PulseAudio plugin shipped with xine-lib upstream is a racy mess, please
integrate this patch I just prepared which fixes all issues I am aware of:

http://0pointer.de/public/xine-pulse-rework.patch

I think this is safe for F9 given the bad quality of the old driver. Even if the
new one is not perfect, it's still far better then the current driver.

Changes:
* Remove the awful mess of racyness
* Remove all usleep() loops
* Implement muting properly
* Support surround sound properly
* Implement Pause/Resume
* Clean other things up

I am posting this upstream now too.
Comment 1 Rex Dieter 2008-03-31 08:51:47 EDT
Now that xine-pulse plugin may actually be useful (pending confirmation) :) ,
I'd propose it be packaged separately (from the rest of -extras) similar to
-arts subpkg.
Comment 2 Rex Dieter 2008-03-31 10:02:10 EDT
And, if there are no objections, yes, I'm volunteering to do/help-with the
packaging work to make that happen.
Comment 3 Ville Skyttä 2008-03-31 14:12:01 EDT
Fine with me.
Comment 4 Lennart Poettering 2008-04-01 14:38:01 EDT
Got merged upstream, BTW.

Anyone objects if I do the commit?
Comment 5 Lennart Poettering 2008-04-01 14:38:26 EDT
(of course, assuming the ACLs are properly set...)
Comment 6 Lennart Poettering 2008-04-02 17:07:17 EDT
I updated this patch again: 

http://0pointer.de/public/xine-pulse-rework2.patch

Fixes another limitation of the original driver: unbreaks driver autoprobing.
Comment 7 Kevin Kofler 2008-04-06 03:32:33 EDT
That patch is a 404, do you mean this?
http://0pointer.de/public/xine-pulse-rework-fixup.patch
Comment 8 Lennart Poettering 2008-04-07 08:09:34 EDT
Uh, fixed the URL.

rework+fixup is the same as rework2.
Comment 9 Rex Dieter 2008-04-07 09:08:57 EDT
OK, let's give this a whirl:

* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.1.11.1-2
- pulse-rework2 patch (#439731)
- -pulseaudio subpkg (#439731)
Comment 10 Julian Sikorski 2008-04-07 09:16:07 EDT
Are there any chances for seeing this update in Fedora 8?
Comment 11 Rex Dieter 2008-04-07 09:24:59 EDT
of course, just give us a chance to at least test it a little first. :)
Comment 12 Julian Sikorski 2008-04-07 09:29:42 EDT
OK :)
Comment 13 Rex Dieter 2008-04-07 14:00:44 EDT
*** Bug 345461 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Kofler 2008-04-07 16:56:11 EDT
Rex, I added a small patch to kdebase-runtime which enables the backend in 
Phonon, we can add it to the specfile and build it as soon as you're 
comfortable with doing it. We'll also want kde-settings-pulseaudio to Requires: 
xine-lib-pulseaudio.

Note You need to log in before you can comment on or make changes to this bug.