Bug 345531 - Create a gtkhtml38 package for RHEL 5.2
Create a gtkhtml38 package for RHEL 5.2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 12:57 EDT by Matthew Barnes
Modified: 2008-01-22 22:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 18:41:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2007-10-22 12:57:47 EDT
For RHEL 5.2 we are rebasing Evolution to match Fedora 8 (bug #318591).  The
gtkhtml3 package will also be rebased as part of this effort.

Between RHEL 5.0 and Fedora 8, the printing API in GtkHtml changed from using
the GnomePrint library to the newer printing API in GTK+.  This broke GnuCash,
which still depends on GtkHtml's older GnomePrint-based printing API.

For Fedora 7, Bill Nottingham created a new "gtkhtml38" package which preserved
the older printing API (libgtkhtml-3.8.so) for use with GnuCash.

I propose doing the same for RHEL 5.2.  Specifically, create a new "gtkhtml38"
package which is a snapshot of the gtkhtml3 package we shipped in RHEL 5.1, so
that gtkhtml3 can be safely rebased without breaking GnuCash.
Comment 1 RHEL Product and Program Management 2007-10-22 13:04:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Bill Nottingham 2007-10-22 15:10:24 EDT
Note that gnucash isn't in RHEL 5, only in EPEL. But there could be other
third-party apps using gtkhtml3.
Comment 4 Matthew Barnes 2008-01-15 11:09:51 EST
Package created as gtkhtml38-3.12.0-2.el5.
Comment 10 Matthew Barnes 2008-01-22 19:56:32 EST
notting: Do you want to just add this package to EPEL for GnuCash?
Comment 11 Bill Nottingham 2008-01-22 22:15:41 EST
Hm, I may do that. I guess for EPEL I have to wait until closer to the 5.2 release.

Note You need to log in before you can comment on or make changes to this bug.