Bug 345641 - Installer crashed when loading it
Installer crashed when loading it
Status: CLOSED DUPLICATE of bug 321251
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 13:57 EDT by Robert Uhlig
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 14:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Uhlig 2007-10-22 13:57:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.6) Gecko/20070925 Fedora/2.0.0.6-10.fc8 Firefox/2.0.0.6

Description of problem:
Component: pirut
Summary: TB19ba829d __init__.py:158:pirutCDHandler:NameError: global name 'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 474, in <module>
    main()
  File "/usr/sbin/pirut", line 470, in main
    pm.run()
  File "/usr/sbin/pirut", line 398, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 414, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in _check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative = relative, text = text, copy_local = copy_local, url = url, mediaid = self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 158, in pirutCDHandler
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
cddevs: dbus.Array([dbus.String(u'/org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_4163B'), dbus.String(u'/org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_4040B')], signature=dbus.Signature('s'))
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at 0x1018bf0> :1.4 /org/freedesktop/Hal/Manager at 0x10e4990> implementing 'org.freedesktop.Hal.Manager' at 0x10e4a10>
name: Fedora 7.92
self: <__main__.PackageManager object at 0x1014a90>
args: ()
umount: False
mediaid: 1191242166.874799
HalCD: <module 'pirut.HalCD' from '/usr/lib/python2.5/site-packages/pirut/HalCD.pyc'>
dev: <pirut.HalCD.HALBlockDevice instance at 0x15789e0>
discnum: 1
kwargs: {'mediaid': '1191242166.874799', 'name': 'Fedora 7.92', 'url': None, 'text': <yum.yumRepo.YumRepository object at 0x10d52d0>, 'relative': 'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x10d52d0>>, (), {}), 'copy_local': 1, 'discnum': 1, 'local': '//var/cache/yum/InstallMedia/repomd.xml'}
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_4163B

Version-Release number of selected component (if applicable):
pirut-1.3.20-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. On start, nothing else
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Jeremy Katz 2007-10-22 14:24:26 EDT

*** This bug has been marked as a duplicate of 321251 ***

Note You need to log in before you can comment on or make changes to this bug.