Bug 346 - Screen takes a long time to switch over telnet
Screen takes a long time to switch over telnet
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: screen (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
: 846 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-08 05:10 EST by thomas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-01-17 09:27:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description thomas 1998-12-08 05:10:48 EST
With the introduction of redhat 5.1, screen shows a delay of
up to 5 seconds, depending on screen content, to switch
between virtual consoles over any kind of network conenction
(telnet/ssh), in 5.0 and prior the switchover occured almost
immediately. As not only the screen RPM's but also custom
complied versions are affected, i am suspecting a problem in
the curses libraries.
Comment 1 David Lawrence 1998-12-09 16:49:59 EST
Tried this in the lab, and things worked with full-screen ps
displays.  Delay of less than a second.  By any chance are you seeing
network delays that are resulting in the lag, or is there some other
display that we should try this with?
Comment 2 thomas 1998-12-10 08:42:59 EST
Red Hat Linux release 5.1 (Manhattan)
Linux tesla.femu.rwth-aachen.de 2.0.35 #7 Tue Sep 8 13:53:25 CEST 1998
i686 unknown
 10:12am  up 57 days, 23:32,  2 users,  load average: 0.00, 0.00, 0.00
Screen version 3.07.04 (FAU) 23-Jun-97

Using ZOC V3.10 in both Telnet and SSH mode, terminal emulation VT220
in 164x54 character resolution, i do the following:

screen # invoke screen
man ls # fill the first screen with a man page
ctrl+a c # create second screen
man cp # fill the second screen with a man page
ctrl+a 0 # switch back to first screen

The time between the 0 and the actual switchover is 9 seconds.
Same if i switch back to screen 1 with ctrl+a 1.

If i invoke a 3rd screen and leave it empty, the switchover to that
EMPTY screen takes about 1,5 seconds, the switch back to a screen with
content (man pages, etc) the same 9 seconds mentioned above.

Up till and including redhat 5.0 this was working instantaneously

(p.s. the host machine is a dual PII-400, 512 MB Ram, switched
100baseT network. The client machine a single PII-350 with 128 MB ram
running windows95OSR2 and ZOC Terminal program (www.emtec.com).
Network utilisation at 3% during the test.
The behaviour can be reproduced on all other linux hosts running
redhat here, whether it be alpha or intel version (no Sparc, sorry),
as soon as i try it on a 5.0 distribution switchover times are
typically less than 0,5 seconds.
Comment 3 Jay Turner 1998-12-10 10:55:59 EST
In test lab, telneted in from Win98 terminal to Linux host and did see
longer than usual delay in screen switches.  Not able to see same
delays telneted in from Linux workstations.  Tried with 4.2 system in
lab and sure enough switches were quicker!
Comment 4 Jeff Johnson 1999-01-12 10:46:59 EST
From Alan Cox during Red Hat 5.2beta2:

screen is still broken.

        Set the terminal type to vt100 (or better yet get a real
        vt100) and try switching screens or doing things like an
        ls -lR / - it crawls. This is a known problem with screen
        and ncurses4.
Comment 5 Jeff Johnson 1999-01-17 09:20:59 EST
*** Bug 346 has been marked as a duplicate of this bug. ***

>
> The system is an upgrade from RedHat 5.0 and under 5.0,
screen had
> extremely quick response times in doing a switch from
screen to screen as
> well as doing something as simple as doing an ls in the
/etc directory.
>
> Under RedHat 5.2 however, fliping from one screen to the
next takes at
> least 3-4 seconds, and doing a directory listing under
/etc (ls) results
> in the first line appearing immediately, then the rest of
the listing
> appearing 2-3 seconds later.
>
> Is this a problem with the machine, OS, or should I
recompile screen.

It's a ncurses problem. Our new version contains a
workaround. You
can get it from:

ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-3.7.6.
tar.gz

------- Additional Comments From ayn2@cornell.edu  01/15/99 23:29 -------
This is a duplicate of #346

------- Additional Comments From mchoi@ap.net.hk  01/16/99 00:20 -------
Sorry, first time posting on bigzilla, didn't see the previous post.

I compiled the new screen version(3.7.6) and all problems are gone.

The Linux Server machine is only a pentium 166 with 128MB RAM and a
6.4 GB IDE Drive.
Comment 6 Jeff Johnson 1999-01-17 09:27:59 EST
Screen 3.76 is part of Raw Hide. Get the source rpm from there and
recompile if you want to correct this problem.
Comment 7 Jeff Johnson 1999-01-17 09:29:59 EST
The source rpm in Raw Hide is screen-3.7.6-1.src.rpm (not 3.76).
Sorry for the confusion.

Note You need to log in before you can comment on or make changes to this bug.