Bug 34611 - Japanese gnome-game:menu cant be displayed
Japanese gnome-game:menu cant be displayed
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
:
: 48324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 23:11 EDT by Bill Huang
Modified: 2016-11-24 10:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:18:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Iconv test program for iconv-not-working-when setgid problem. (576 bytes, text/plain)
2001-07-20 11:38 EDT, Owen Taylor
no flags Details

  None (edit)
Description Bill Huang 2001-04-03 23:11:32 EDT
In Japanese gnome-game,Japanese menu can't be displayed.
Comment 1 Bill Huang 2001-04-10 09:32:32 EDT
The properity of the file looks strange:

[bhuang@station3 bhuang]$ ls -al /usr/bin/mahjongg
-r-xr-s--x    1 root     games       45356  27n 28 05:33 /usr/bin/mahjongg
[bhuang@station3 bhuang]$ su
Password:
[root@station3 bhuang]# chmod g-s /usr/bin/mahjongg
[root@station3 bhuang]# ls -al /usr/bin/mahjongg
-r-xr-x--x    1 root     games       45356  27n 28 05:33 /usr/bin/mahjongg
[root@station3 bhuang]#

After chmod g-s ,Japanese menu can be displayed properly.
Comment 2 Bill Huang 2001-04-13 03:16:43 EDT
If sticky bit of the program is not disabled,after newgrp games,
Japanese menu can also be displayed properly.
Comment 3 Akira TAGOH 2001-04-15 23:00:56 EDT
Temporary it seems we can solve this problem to add as the follow line to
/etc/ld.so.conf:

/usr/lib/gconv

is this glibc's bug?
Comment 4 Akira TAGOH 2001-04-19 10:26:14 EDT
This problem occurred when GTK+ 1.2.9 didn't support setuid/setgid program.
the application which uses the setgid must be execute via wrapper/helper.
Comment 5 Owen Taylor 2001-07-20 11:38:12 EDT
I don't think this has anything to do with GTK+ or the GTK+-1.2.9
change (which doesn't trigger for gnome-score usage since the
games have dropped their setgid privileges before they invoke
GTK+)

The attached simple iconv test works fine normally, fails with
setgid games. Perhaps adding /usr/lib/gconv to /etc/ld.so.conf
is the right solution ... presumably there is some security
check to disable dlopen'ing gconv modules from non-system 
directories when running setuid/setgid.
Comment 6 Owen Taylor 2001-07-20 11:38:59 EDT
Created attachment 24310 [details]
Iconv test program for iconv-not-working-when setgid problem.
Comment 7 Jakub Jelinek 2001-07-23 14:39:58 EDT
Glibc has several security checks which are in place during loading and dlopen
from suid/sgid application.
This particularly is because iconv dlopens a iconv module which needs another
library (libJIS.so) and has DT_RPATH $ORIGIN. But $ORIGIN handling is
disallowed for SUID/SGID programs.
Ulrich, do you think dl-load.c could special case this (ie.
__libc_enable_secure && DT_RPATH equal to "$ORIGIN" && l->l_origin is GCONV_PATH)
or do you have other suggestions?
Comment 8 Ulrich Drepper 2001-07-23 15:16:47 EDT
Always try the latest CVS version first.  It all should work now.
Comment 9 Nakai 2001-08-01 12:00:02 EDT
*** Bug 48324 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Jelinek 2001-09-06 12:50:19 EDT
Oops, forgot to close. Should be fixed since glibc-2.2.3-15.
Comment 11 Bill Nottingham 2006-08-04 16:18:37 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.