Bug 34654 - Grapical installer chrashes(allso in text mode when no mouse) just before instaling packages
Grapical installer chrashes(allso in text mode when no mouse) just before ins...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 36629 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 05:55 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 12:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback (829 bytes, text/plain)
2001-04-04 05:56 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-04-04 05:55:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


Grapical installer chrashes(allso in text mode when no mouse) just before 
instaling packages, the text mode installer however dosen't

Reproducible: Always
Steps to Reproduce:
1.start installation grapicly
2.mark select indiviual packages
3.select some packages(perhaps on cd 2)
4. wach the installer chrash
	

Actual Results:  a bugreport came up with a backtrace

Expected Results:  it should proceed to install

Heres what it said:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1469, in 
doInstall
    self.fstab.makeFilesystems ()
  File "fstab.py", line 594, in makeFilesystems
    isys.makeDevInode(device, '/tmp/' + device)
  File "isys.py", line 195, in makeDevInode
    return _isys.mkdevinode(name, fn)
SystemError: (17, 'File exists')

Local variables in innermost frame:
fn: /tmp/hda1
name: hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2001-04-04 05:56:06 EDT
Created attachment 14603 [details]
traceback
Comment 2 Brent Fox 2001-04-09 16:02:38 EDT
Does the install still hang if you use text mode?
Comment 3 Brent Fox 2001-04-20 00:11:47 EDT
How big are you trying to make your / partition?
Comment 4 Need Real Name 2001-04-21 07:39:08 EDT
the installer does not chrash if i use "text" to install, nor if I don't select
individual packages.
The / partition is 450 MB
How ever it is not due to lack of space, if i select the same packages in txt
mode the installaton goes along smoothly
Comment 5 Michael Goszczynski 2001-05-06 17:14:23 EDT
On my machine anaconda crashes each time, even in text mode.
My hardware is:
AMD K-5 PR@100 MHz
16 MB RAM
3.2 GB & 8.4 GB Hard-drives
Comment 6 Brent Fox 2001-05-07 18:08:54 EDT
*** Bug 36629 has been marked as a duplicate of this bug. ***
Comment 7 Jitendra Kulkarni 2001-05-27 02:27:46 EDT
I have PII450, 64MB Ram No SCSI. Instllation crashed 99% of time in GUI. I got 
only one install in around 20 tries and that was partitionless, so useless.  
All the failures were while tranferring image to disk. Once I got a 
partitionless install but postinstall script hung. After
reading this report, I tried GUI without individual pacckage selection, install 
crashed at the same place it used to: while transferring install image to the 
disk. The I tried text mode without individual pacckage selection. It worked.
Comment 8 Brent Fox 2001-06-12 23:27:11 EDT
I don't really know what is causing this problem.  Have you tried 7.1?
Comment 9 Brent Fox 2001-06-25 12:46:11 EDT
Closing due to inactivity. Please reopen if you have more information.
Comment 10 Michael Goszczynski 2001-10-28 03:55:25 EST
Unforyunatelly, the same bug occurs in Red Hat 7.1.

Note You need to log in before you can comment on or make changes to this bug.