Bug 346801 - Port dhcp to use NSS library for cryptography
Port dhcp to use NSS library for cryptography
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:17 EDT by Peter Vrabec
Modified: 2012-08-17 10:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 10:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcp-4.0.0-nss.patch (8.35 KB, patch)
2009-09-21 16:24 EDT, David Cantrell
no flags Details | Diff
dhcp-4.1.0-nss.patch (16.20 KB, patch)
2009-09-21 16:24 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description Peter Vrabec 2007-10-23 06:17:33 EDT
dhcp should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 David Cantrell 2007-10-23 10:45:29 EDT
dhcp (both dhcpd and dhclient and dhcrelay) does not have any built-in
authentication code.  dhcpd links with with libldap for sites wanting to store
DHCP server configuration data in an LDAP directory, so any authentication that
happens around DHCP is for connecting to the LDAP server and that's all handled
by OpenLDAP.
Comment 2 Tomas Mraz 2007-10-23 10:55:36 EDT
It contains built in MD5 and HMAC-MD5 algorithms. If they are used in security
relevant context they should be replaced with calls to NSS.
Comment 3 David Cantrell 2007-10-23 11:03:41 EDT
Oh right, my bad.  For the dnssec stuff.
Comment 4 David Cantrell 2009-09-21 16:24:17 EDT
Created attachment 361986 [details]
dhcp-4.0.0-nss.patch
Comment 5 David Cantrell 2009-09-21 16:24:38 EDT
Created attachment 361988 [details]
dhcp-4.1.0-nss.patch
Comment 6 David Cantrell 2009-09-21 16:25:09 EDT
I've attached two patches I started to convert dhcp to the NSS libraries.  Both patches are incomplete, but might be a starting place.
Comment 7 Jiri Popelka 2012-08-17 10:41:10 EDT
ISC DHCP hasn't used the code mentioned in comment #2 since version 4.2.0, see bug #849166.

Closing therefore.

Note You need to log in before you can comment on or make changes to this bug.