Bug 34738 - RH upgrade crashes if a Linux partition has no valid filesystem
RH upgrade crashes if a Linux partition has no valid filesystem
Status: CLOSED DUPLICATE of bug 20006
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 12:40 EDT by Jason Grant
Modified: 2007-03-26 23:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 15:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Grant 2001-04-04 12:40:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.18 i686; Nav)


Anaconda crashes while searching for previous RH installations if any
partition is marked as "Linux" but doesn't have a valid file system.  The
anaconda updates don't fix this problem.

Reproducible: Always
Steps to Reproduce:
1. start install
2. select keyboard, etc.
3. choose "upgrade"
4. anaconda crashes while searching for previous RH installations 
	

Actual Results:  anacdump.txt:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line
30, in getScreen
    self.parts = self.todo.upgradeFindRoot ()
  File "/tmp/updates/todo.py", line 881, in upgradeFindRoot
    isys.umount('/mnt/sysimage')
  File "isys.py", line 113, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Creating a file system on the partition in question fixes things, but the
installer should be more robust...
Comment 1 Brent Fox 2001-04-04 15:50:57 EDT

*** This bug has been marked as a duplicate of 20006 ***
Comment 2 Brent Fox 2001-04-04 16:05:53 EDT
Applied the following patch:

diff -u -r1.92 it.po
--- it.po       2001/04/03 22:44:26     1.92
+++ it.po       2001/04/04 19:40:14
@@ -4366,7 +4366,8 @@
 "\n"
 "    o il nome o l'indirizzo IP del server web\n"
 "    o la directory presente sul server che contiene\n"
-"      il software Red Hat Linux specifico per la vostra architettura\n"
+"      il software Red Hat Linux specifico per la \n"
+"      vostra architettura\n"
 
 #: ../loader/urls.c:187


This should fix the problem.  Change should appear in the qa0405 trees and
beyond.  Thanks for your following up on this one.
Comment 3 Brent Fox 2001-04-04 16:06:47 EDT
Whoops...committed to the wrong bug.  Please disregard my last post.

Note You need to log in before you can comment on or make changes to this bug.