Bug 20006 - ANACDUMP.TXT
ANACDUMP.TXT
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 19979 20152 20672 22733 22827 24531 34738 67348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-29 15:14 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 12:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ANACDUMP.TXT (793 bytes, text/plain)
2000-10-29 15:14 EST, Need Real Name
no flags Details
Bug output traceback (11.22 KB, text/plain)
2001-08-29 20:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-29 15:14:18 EST
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1588, in 
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "fstab.py", line 503, in umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File "isys.py", line 113, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage/win98
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Need Real Name 2000-10-29 15:14:58 EST
Created attachment 4736 [details]
ANACDUMP.TXT
Comment 2 Michael Fulbright 2000-10-31 10:48:29 EST
Could you please give the steps required to duplicate this problem?
Comment 3 Need Real Name 2000-11-01 01:18:16 EST
I haven't reproduced it.  When it happened, Anaconda asked me to report the 
bug - so I did.

I think it happened when trying to install Linux 7.0 on my DELL Inspiron 7500 
laptop.  I had chosen Custom Install and all packages - the partition I was 
installing too was too small.  I can't remember the exact conditions, when I 
enlarged the partition and tried again to install, all went fine.
Comment 4 Alan Hamilton 2000-11-03 03:41:51 EST
I had a failed install that caused the same error.  The cause was RAID0 
partitions that had the partition types set to Linux (83) rather than Linux 
raid autodetect (FD).  The kernel's raid routines ignore the partition type and 
check each actual disk partition for a signature, so the system under normal 
circumstances will operate just fine like this.  However, the installer tries 
to mount the individual partitions of the RAID array as ext2 partitions.  This 
doesn't cause an error at first (see below), so the installer doesn't seem to 
catch it.  When it tries to unmount the partition, it's not mounted properly 
and that causes an unhandled exception.  This occurs with RHBA-2000:084-04.  
Although the relase notes that it is supposed to fix crashes on mounting non-
Linux partitions, I don't think this situation was anticipated.

It appears that mount will successfully mount the first volume in a linear 
(RAID0) set, but it won't operate correctly as a filesystem.

# mount -r -t ext2 /dev/hdb1 /mnt/foo
# ls -l /mnt/foo
?---------    0 root     root            0 Dec 31  1969 /mnt/foo
# umount /mnt/foo
# ls -l /mnt/foo
total 0

This crashes the installer.  Setting the partition type to something besides 
regular Linux makes the installer skip it.

Anyway, changing the partition types to FB resolved the error.
Comment 5 Alan Hamilton 2000-11-03 03:44:07 EST
Er, correction, partition type *FD*.
Comment 6 Michael Fulbright 2000-11-03 15:09:10 EST
*** Bug 20152 has been marked as a duplicate of this bug. ***
Comment 7 Brock Organ 2000-11-06 18:28:42 EST
c.abeln,

Please let us know if you are able to reproduce this error ... and thanks for
your report!

alanh,

this sounds like a corner case, we'll consider that as an enhancement request
... thanks for your notes!
Comment 8 Michael Fulbright 2000-11-13 15:25:08 EST
*** Bug 19979 has been marked as a duplicate of this bug. ***
Comment 9 Need Real Name 2000-11-13 16:48:12 EST
No, I'm sorry, I haven't been able to reproduce it.  What do you want me to do 
next time it happens?
Comment 10 Michael Fulbright 2000-12-04 10:23:18 EST
*** Bug 20672 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-12-27 11:52:53 EST
*** Bug 22827 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2001-01-09 18:08:06 EST
*** Bug 22733 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2001-01-24 16:16:18 EST
*** Bug 24531 has been marked as a duplicate of this bug. ***
Comment 14 Brent Fox 2001-04-04 15:50:52 EDT
*** Bug 34738 has been marked as a duplicate of this bug. ***
Comment 15 Brent Fox 2001-04-19 17:04:37 EDT
*** Bug 36399 has been marked as a duplicate of this bug. ***
Comment 16 Need Real Name 2001-08-29 20:07:58 EDT
Created attachment 30154 [details]
Bug output traceback
Comment 17 Need Real Name 2001-08-29 20:09:56 EDT
I've experienced what appears to be the same problem. I have a RAID0 HPT370 
configuration, and was able to recreate the problem twice (text and gui mode 
install). I've attached the output from the installer when it croaked onto this 
bug report.
Comment 18 Need Real Name 2001-08-29 20:12:58 EDT
The traceback is not the same. The symptoms are the same. I will try to bypass 
this now using alanh's comments. I reported this anyway cause perhaps my output 
will do some good .. (or point me in another direction in case I am wrong about 
the fact that it is a duplicate). Thanks !
Comment 19 Michael Fulbright 2002-06-26 00:00:43 EDT
*** Bug 67348 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.