Bug 34767 - RHN receipt has invalid content
RHN receipt has invalid content
Status: CLOSED DEFERRED
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
: 40832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 16:56 EDT by Jay Turner
Modified: 2015-01-07 18:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 20:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-04-04 16:56:34 EDT
Place an order on cprince.devel.webdevel.redhat.com for RHN subscription,
then get to the order receipt.  Notice that there is text at the bottom of
the receipt mentions products, as well as CCVS services.  Really should
just have a receipt which is specific to the RHN process.
Comment 1 Jason Kohles 2001-04-25 14:49:43 EDT
Fixed, receipt now hides the additional information if the only things in your
cart are RHN subscriptions.
Comment 2 Jay Turner 2001-05-01 10:38:33 EDT
On http://webdevel.redhat.com we are getting closer to what we need.  After
placing an order for just a single RHN subscription, I get the invoice and the
order number is missing from the page.  In addition, there is a line item for
shipping (should not be there) and a line item for tax (should only be there is
!= 0)  Furthermore, there is no text about the fact this is a recurrent charge.
Also, the shipping address should not appear in this case, as it just doesn't
make sense.
Comment 3 David Totten 2001-05-04 17:49:53 EDT
I have been researching the order number part of this issue, and it looks like
this only happens when you order product_id number 5583, (Red Hat Network
Software Manager). I am not sure yet why it is so unique, but I thought I would
post these findings so that maybe someone would say Aha! :)

I will continue looking into this
Comment 4 Cameron Prince 2001-05-11 01:23:29 EDT
We couldn't really make a receipt specific to RHN due to allowing different 
item types to be purchased at once. But we did add code to limit the display of 
unrelated text.

If you don't by a service, such as CVS, you won't get the related text. If you 
don't by training, you won't be shown training text.

This should be fixed based on the info we have and test orders from existing 
store.
Comment 5 Jay Turner 2001-05-14 16:23:25 EDT
OK, just placed an order for 2 boxed sets.  The resulting receipt has:
 A charge of $401.69 will be made to your credit card. If you have ordered a
physical item (i.e. not a service), the charge will be made upon shipment. You
will receive confirmation via e-mail when the order has been shipped.
If you have purchased a service from Red Hat, such as Software Manager,
Developer Support, or System Reliability Service, your credit card will be
charged immediately.

I don't think that we should have anything on here about the services, as the
user did not purchase a service.  He purchased a boxed set.  Now, ordering the
CCVS service package does cause additional content to be displayed on the
receipt, so if the fixups that we have done to this point are as good as it
gets, we will just have to wait til phase II to get further customization.
Comment 6 Cameron Prince 2001-06-07 10:51:54 EDT
Still waiting on content for the html receipt and email confirmation. We have
the ability to display info based on what type of things were purchased. Just
need to drop it in.
Comment 7 Cameron Prince 2001-06-07 20:46:03 EDT
*** Bug 40832 has been marked as a duplicate of this bug. ***
Comment 8 Cameron Prince 2001-06-07 20:48:15 EDT
I marked the other receipt content bug as a duplicate of this bug because the
content will likely be very similar.

We have been waiting on this content for some time. The content we added for
multiple order numbers should be reviewed as well.
Comment 9 Jay Turner 2001-09-18 08:15:26 EDT
Deferring this as Interchange did not launch.

Note You need to log in before you can comment on or make changes to this bug.