Bug 34792 - upgrade to rpm-4.0.2-6x fails with script failure
upgrade to rpm-4.0.2-6x fails with script failure
Status: CLOSED DUPLICATE of bug 34062
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 33394 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 20:42 EDT by Anthony Rumble
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 08:58:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Rumble 2001-04-04 20:42:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


Upgrading from rpm-3.0.5-9.6x to rpm-4.0.2-6x fails with "errorexecution of
rpm-4.0.2-6x script failed, exit status 1" 

Reproducible: Always
Steps to Reproduce:
1. rpm -U -v --hash rpm-4.0.2-6x.i386.rpm
2.
3.
	

Actual Results:  execution of rpm-4.0.2-6x script failed, exit status 1
Running with -vv produces this :- D: counting packages to install D: found
1 packages D: looking for packages to download D: retrieved 0 packages D:
New Header signature D: Signature size: 149 D: Signature pad : 3 D: sigsize
: 152 D: Header + Archive: 1283514 D: expected size : 1283514 D: opening
database mode 0x42 in /var/lib/rpm D: found 0 source and 1 binary packages
D: requires: gawk satisfied by db packages. D: requires: fileutils
satisfied by db packages. D: requires: textutils satisfied by db packages.
D: requires: mktemp satisfied by db packages. D: requires: popt satisfied
by db packages. D: requires: /bin/sh satisfied by db file lists. D:
requires: /sbin/ldconfig satisfied by db file lists. D: requires:
ld-linux.so.2 satisfied by db provides. D: requires: libbz2.so.0 satisfied
by db provides. D: requires: libc.so.6 satisfied by db provides. D:
requires: libdb-3.1.so satisfied by db provides.D: requires: libdb.so.2
satisfied by db provides. D: requires: libpopt.so.0 satisfied by db
provides. D: YES A librpm.so.0 B librpm.so.0 D: requires: librpm.so.0
satisfied by added provide. D: YES A librpmbuild.so.0 B librpmbuild.so.0 D:
requires: librpmbuild.so.0 satisfied by added provide. D: YES A
librpmio.so.0 B librpmio.so.0 D: requires: librpmio.so.0 satisfied by added
provide. D: requires: libz.so.1 satisfied by db provides. D: requires:
/bin/sh satisfied by db file lists. D: requires: libc.so.6(GLIBC_2.0)
satisfied by db provides. D: requires: libc.so.6(GLIBC_2.1) satisfied by db
provides. D: requires: libdb.so.2(GLIBC_2.0) satisfied by db provides. D:
NO A patch = 2.5-10 B patch < 2.5 D: conflicts: patch < 2.5 unsatisfied. D:
NO A glibc = 2.1.3-22 B glibc >= 2.1.92 D: conflicts: glibc >= 2.1.92
unsatisfied. D: YES A rpm = 4.0.2-6x B rpm >= 3.0.3 D: requires: rpm >=
3.0.3 satisfied by added package. D: YES A rpm = 4.0.2-6x B rpm >= 3.0.4 D:
requires: rpm >= 3.0.4 satisfied by added package. D: YES A rpm = 4.0.2-6x
B rpm >= 3.0.5 D: requires: rpm >= 3.0.5 satisfied by added package.D: YES
A rpm = 4.0.2-6x B rpm = 4.0.2 D: requires: rpm = 4.0.2 satisfied by added
package. D: YES A rpm = 4.0.2-6x B rpm = 4.0.2 D: requires: rpm = 4.0.2
satisfied by added package. D: YES A rpm = 4.0.2-6x B rpm = 4.0.2 D:
requires: rpm = 4.0.2 satisfied by added package. D: YES A librpm.so.0 B
librpm.so.0 D: requires: librpm.so.0 satisfied by added provide. D: YES A
librpm.so.0 B librpm.so.0 D: requires: librpm.so.0 satisfied by added
provide. D: YES A librpm.so.0 B librpm.so.0 D: requires: librpm.so.0
satisfied by added provide. D: YES A librpmbuild.so.0B librpmbuild.so.0 D:
requires: librpmbuild.so.0 satisfied by added provide. D: installing binary
packages D: getting list of mounted filesystems D: New Header signature D:
Signature size: 149 D: Signature pad : 3 D: sigsize : 152 D: Header +
Archive: 1283514 D: expected size : 1283514 D: package: rpm-4.0.2-6x files
test = 0 D: file: /bin/rpm action: create D: file: /etc/rpm action: create
D: file: /etc/rpm/macros.db1 action: create D: file: /usr/bin/gendiff
action: create D: file: /usr/bin/rpm2cpio action: create D: file:
/usr/bin/rpmdb action: create D: file: /usr/bin/rpme action: create D:
file: /usr/bin/rpmi action: create D: file: /usr/bin/rpmquery action:
create D: file: /usr/bin/rpmsign action: create D: file: /usr/bin/rpmu
action: create D: file: /usr/bin/rpmverify action: create D: file:
/usr/doc/rpm-4.0.2 action: create D: file: /usr/doc/rpm-4.0.2/CHANGES
action: create D: file: /usr/doc/rpm-4.0.2/GROUPS action: create D: file:
/usr/doc/rpm-4.0.2/RPM-GPG-KEY action: create D: file:
/usr/doc/rpm-4.0.2/RPM-PGP-KEY action: create D: file:
/usr/doc/rpm-4.0.2/builddependencies action: create D: file:
/usr/doc/rpm-4.0.2/buildroot action: create D: file:
/usr/doc/rpm-4.0.2/dependencies action: create D: file:
/usr/doc/rpm-4.0.2/format action: create D: file: /usr/doc/rpm-4.0.2/macros
action: create D: file: /usr/doc/rpm-4.0.2/multiplebuilds action: createD:
file: /usr/doc/rpm-4.0.2/queryformat action: create D: file:
/usr/doc/rpm-4.0.2/relocatable action: create D: file:
/usr/doc/rpm-4.0.2/signatures action: create D: file:
/usr/doc/rpm-4.0.2/spec action: create D: file: /usr/doc/rpm-4.0.2/triggers
action: create D: file: /usr/lib/librpm.so.0 action: create D: file:
/usr/lib/librpm.so.0.0.0 action: create D: file: /usr/lib/librpmbuild.so.0
action: create D: file: /usr/lib/librpmbuild.so.0.0.0 action: create D:
file: /usr/lib/librpmio.so.0 action: create D: file:
/usr/lib/librpmio.so.0.0.0 action: create D: file:
/usr/lib/rpm/config.guess action: create D: file: /usr/lib/rpm/config.sub
action: create D: file: /usr/lib/rpm/convertrpmrc.sh action: create D:
file: /usr/lib/rpm/i386-linux action: create D: file:
/usr/lib/rpm/i386-redhat-linux action: create D: file:
/usr/lib/rpm/i386-redhat-linux/macros action: create D: file:
/usr/lib/rpm/i486-linux action: create D: file:
/usr/lib/rpm/i486-redhat-linux action: create D: file:
/usr/lib/rpm/i486-redhat-linux/macros action: create D: file:
/usr/lib/rpm/i586-linux action: create D: file:
/usr/lib/rpm/i586-redhat-linux action: create D: file:
/usr/lib/rpm/i586-redhat-linux/macros action: create D: file:
/usr/lib/rpm/i686-linux action: create D: file:
/usr/lib/rpm/i686-redhat-linux action: create D: file:
/usr/lib/rpm/i686-redhat-linux/macros action: create D: file:
/usr/lib/rpm/macros action: create D: file: /usr/lib/rpm/mkinstalldirs
action: create D: file: /usr/lib/rpm/rpmdb action: create D: file:
/usr/lib/rpm/rpme action: create D: file: /usr/lib/rpm/rpmi action: create
D: file: /usr/lib/rpm/rpmk action: create D: file:
/usr/lib/rpm/rpmpopt-4.0.2 action: create D: file: /usr/lib/rpm/rpmq
action: create D: file: /usr/lib/rpm/rpmrc action: create D: file:
/usr/lib/rpm/rpmu action: create D: file: /usr/lib/rpm/rpmv action: create
D: file: /usr/man/man1/gendiff.1.gz action: create D: file:
/usr/man/man8/rpm.8.gz action: create D: file: /usr/man/man8/rpm2cpio.8.gz
action: create D: file: /usr/man/pl/man8/rpm.8.gz action: create D: file:
/usr/man/ru/man8/rpm.8.gz action: create D: file:
/usr/man/ru/man8/rpm2cpio.8.gz action: create D: file:
/usr/man/sk/man8/rpm.8.gz action: create D: file:
/usr/share/locale/cs/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/da/LC_MESSAGES/rpm.mo action: createD: file:
/usr/share/locale/de/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/fi/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/fr/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/is/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/ja/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/no/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/pl/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/pt/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/ro/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/ru/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/sk/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/sl/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/sr/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/sv/LC_MESSAGES/rpm.mo action: create D: file:
/usr/share/locale/tr/LC_MESSAGES/rpm.mo action: create D: running
preinstall script (if any)
+ [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]
+ exit 1 execution of rpm-4.0.2-6x script failed, exit status 1
Comment 1 Jeff Johnson 2001-04-05 08:58:25 EDT
*** Bug 33394 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2001-04-05 08:59:43 EDT

*** This bug has been marked as a duplicate of 34062 ***

Note You need to log in before you can comment on or make changes to this bug.