Bug 34896 - username not found through nis
username not found through nis
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-05 12:22 EDT by adler
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 16:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2001-04-05 12:22:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25smp i686)


I've setup my system so that it gets its password information from my nis
server. The commands domainname and ypwhich show that I'm properly setup to
pull "nis maps"(?) from my nis server. If I do a ypcat yppasswd I get the
password file from my nis server, yet when I try to log into the system, I
get an error that the username is not found.

Reproducible: Always
Steps to Reproduce:
1.Setup NIS, make your nis server an sgi machine running Irix 6.5. I'm not
sure if this is required or not to reporduce the bug
2.login as a user how is defined in the password file on the nis server
machine.
3.You cannot log in.
4.as root do a 'su - username'. See error "su: user username does not
exist"

	

Here is an example...

[root@phyppro1 /root]# su - adler
su: user adler does not exist
[root@phyppro1 /root]# domainname
phy
[root@phyppro1 /root]# ypwhich
physgi00.phy.bnl.gov
[root@phyppro1 /root]# ypcat passwd | grep adler
adler:XXXXXXXX:29472:29472:Stephen S. Adler,BNL,Physics 510; 2-67, (516)
282-5682,:/users/usr0/adler:/bin/tcsh

Note: I replaced the password field with XXXXXXX since I didn't not want to
proadcast this hash across the nextwork.
Comment 1 Nalin Dahyabhai 2001-04-05 14:13:00 EDT
Do you have a firewall enabled?  As noted in the release notes, this will block
any RPC-based services such as NIS.  Is "nis" listed on the "passwd:" line in
/etc/nsswitch.conf (it should be, but there's no harm in checking)?  Do you get
any output from "getent passwd adler"?
Comment 2 Florian La Roche 2001-04-05 14:18:47 EDT
Everything should work fine if you either use /usr/sbin/authconfig to configure
the yp
server or if you edit /etc/nsswitch.conf and enable nis lookups.

Does this help to get it running?

Comment 3 adler 2001-04-05 16:12:11 EDT
I believe I've found the problem. the file /etc/nisswitch did not
have 'nis' entries for the password file. I don't understand
why ypcat worked, even though /etc/nisswitch did not have
and 'nis' entry in the file for passwd and group files. It
would be nice that by default, nis was the last in the list
of "nis options". In anycase, once I added "nis" to the
list of "where to get file from", the system was able to
identify the user at login.


Note You need to log in before you can comment on or make changes to this bug.