Bug 349051 - Rename rpm-build to rpmbuild or add a provides
Rename rpm-build to rpmbuild or add a provides
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 12:56 EDT by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 04:08:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2007-10-23 12:56:08 EDT
Description of problem:

The command is called rpmbuild while the rpm is called rpm-build. Get rid of
this inconsistency by doing a rename or adding a provides atleast.
Comment 1 Jeff Johnson 2007-10-23 18:21:27 EDT
The command is called "ls" while the rpm is called "coreutils". Get rid of
this inconsistency by doing a rename or adding a provides at least.
Comment 2 Panu Matilainen 2007-10-24 04:08:53 EDT
There's been some confusion due to rpm manpage referring to "rpmbuild package"
when it meant "the package containing rpmbuild" (see bug #233232), this has been
addressed in 4.4.2.2 manual.

Other than that, WONTFIX, adding provides for executable names is just
unnecessary provide-space pollution. 
Comment 3 Panu Matilainen 2007-10-24 04:11:22 EDT
Hmm.. slight correction, the manpage fix is not in 4.4.2.2 but will be in
4.4.2.3 whenever that gets released.
Comment 4 Rahul Sundaram 2007-10-24 05:27:15 EDT
The idea behind adding a provides is that a user that do

# yum install rpmbuld 

Coreutils example is silly since it is a collection of different commands unlike
rpmbuild. 
Comment 5 Panu Matilainen 2007-10-24 05:42:17 EDT
I do know what the idea is, I just don't buy it. Package names have zero to do
with executable names (even if they in some cases happen to match) and I'm not
going to add provide-pollution to fuel the illusion.

Yum could do an automatic search for matching binary names when a given package
is not found, that'd accomplish the same task without any extra provides.

Note You need to log in before you can comment on or make changes to this bug.