Bug 349531 - Determining file type by glob for some filename masks
Determining file type by glob for some filename masks
Status: CLOSED DUPLICATE of bug 208714
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Depends On:
  Show dependency treegraph
Reported: 2007-10-23 16:54 EDT by Matěj Cepl
Modified: 2013-06-23 22:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-06 10:36:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
test (21.65 KB, application/octet-stream)
2008-04-03 09:56 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2007-10-23 16:54:26 EDT
Description of problem:
Being a bugmaster for the desktop two files we ask almost all reporters for
xorg-x11* components are /etc/X11/xorg.conf and /var/log/Xorg.0.log. Quite often
people don't call the attachments by this name, but they have different subtle
changes in the name of the attachment (like xorg-conf-hostname etc.) and in
almost cases, they don't select by hand, that the attachment is of the type
text/plain. The result of all this is that something like 80% of all attachments
are marked as application/octet-stream, which makes handling with them more
complicated (e.g., Firefox doesn't display them, but only downloads them).

Would it be possible to extend the mechanism for indicating type of attachments
so that default (of course, just default manually selected file types would not
be overriden) could be influenced by the list of file name masks which managers
of different components could extend. So for example, in my case I would say
that anything matching *Xorg*log* and *xorg*conf* would default to text/plain.

Does it make any sense?
Comment 1 Matěj Cepl 2008-02-06 10:36:20 EST

*** This bug has been marked as a duplicate of 208714 ***
Comment 2 Matěj Cepl 2008-04-03 09:56:53 EDT
Created attachment 300250 [details]

Note You need to log in before you can comment on or make changes to this bug.