This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208714 - autodetect attachment type prefers application/octet-stream to text/plain
autodetect attachment type prefers application/octet-stream to text/plain
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
: 349531 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 13:16 EDT by John Reiser
Modified: 2013-06-23 22:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 10:37:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-09-30 13:16:25 EDT
Description of problem: If an attachment MIME type is not specified, then
bugzilla prefers application/octet-stream even when text/plain is correct. 
Text/plain is much more usable because all browsers can deal with it, so you can
View attachments easily directly from bugzilla.


Version-Release number of selected component (if applicable):
2.18

How reproducible:
always

Steps to Reproduce:
1. Browse to select a text file to attach
2. Let bugzilla auto-detect file type (instead of manually selecting text/plain)
3.
  
Actual results:
An actual text/plain file is auto-detected as application/octet-stream.

Expected results:
Actual text/plain is auto-detected as text/plain.

Additional info:
See attachments #2 and #3 to Bug #208712.  These are perfectly good text files
(no control characters except '\n' and possibly '\t') but bugzilla chose
application/octet-stream.  I changed it afterwards, using Edit.
Comment 1 Matěj Cepl 2007-12-21 08:44:45 EST
Alternative solution for this would be to allow list of patterns (probably
normal glob patterns would be enough) which would we mean that for example
anything which looks like xorg.conf or Xorg.*.log* would end up as text/plain
(and not like now in application/octet-stream).

Of course, the solution suggested in this bug report would be OK as well. But
somebody should do something about it -- I waste tons of time on fixing freezing
MIME types.
Comment 2 Matěj Cepl 2008-02-06 10:36:21 EST
*** Bug 349531 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.