Bug 349981 - NetworkManager not letting me use iwl4965 wireless
NetworkManager not letting me use iwl4965 wireless
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 00:29 EDT by Kevin Larkin
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.23.1-20.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 09:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (24.11 KB, text/plain)
2007-10-24 00:29 EDT, Kevin Larkin
no flags Details
lspci output (10.54 KB, text/plain)
2007-10-24 00:30 EDT, Kevin Larkin
no flags Details

  None (edit)
Description Kevin Larkin 2007-10-24 00:29:51 EDT
NetworkManager does not let me select wireless.  Only wired is available for use.

NetworkManager-0.7.0-0.3.svn2995.fc8
kernel-2.6.23.1-31.fc8

Steps to reproduce:

Never works.

Attaching lspci and dmesg outputs.
Comment 1 Kevin Larkin 2007-10-24 00:29:51 EDT
Created attachment 235861 [details]
dmesg output
Comment 2 Kevin Larkin 2007-10-24 00:30:52 EDT
Created attachment 235871 [details]
lspci output
Comment 3 Dan Williams 2007-10-24 15:39:06 EDT
Can you try to delete the following files?  I've encountered issues with 4965
and 3945 when the following files are present.  Removing them and letting the
initscript stuff clear it's head has worked in the past.

/etc/udev/rules.d/70-persistent-net.rules
/etc/sysconfig/network-scripts/ifcfg-wlan0

Before you do this, could you provide the output of:

ls /sys/class/net

Thanks!
Comment 4 Kevin Larkin 2007-10-24 16:16:54 EDT
[hondaman@localhost ~]$ ls /sys/class/net
eth1  lo

There was no ifcfg-wlan0, only ifcfg-wlan0.bak, and I removed it.

Rebooted, and NM does not show a wireless option yet.
Comment 5 Kevin Larkin 2007-10-25 02:12:17 EDT
I just installed the latest koji kernel, and it seems to have fixed my wireless

kernel-2.6.23.1-35.fc8

I have now connected to my WAP!
Comment 6 Rick Stevens 2007-10-31 17:32:15 EDT
I've noticed a similar behavior on 2.6.23.1-10.fc7 on x86_64.  iwl4965 doesn't
start normally.  If you "rmmod iwl4965;modprobeiwl4965" then "ifup wlan0", things
work.  Is udev taking too long to set things up based on the startup sequences?
Comment 7 Warren Togami 2007-10-31 17:38:14 EDT
> If you "rmmod iwl4965;modprobeiwl4965" then "ifup wlan0", things
> work.  Is udev taking too long to set things up based on the startup sequences?

* Fri Oct 26 2007 John W. Linville <linville@redhat.com>
- iwlwifi: clear irqs before enabling them

This problem got a lot better for my iwl3945 on F8 after this patch that went
into -37 on October 26th.  -10 on F7 is October 19th, so it wouldn't have this
patch.  You could try that patch?
Comment 8 Robert 'Bob' Jensen 2007-10-31 18:04:17 EDT
2.6.23.1-17.fc7 from koji requires me to rmmod and modprobe iwl4065 but my
wireless does come up. Does it have the patch in question? I am betting Bug
340221 is related or a dupe. 

I am downloading 2.6.23.1-19.fc7 now from koji.
Comment 9 Dan Williams 2007-10-31 18:32:59 EDT
-> kernel then since it's a kernel thing
Comment 10 Chuck Ebbert 2007-10-31 18:58:24 EDT
F8 bug is fixed, but same bug is in F7
Comment 11 Warren Togami 2007-10-31 21:21:07 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=23094
-20 for F7 is being built now apparently with the patch mentioned above.
Comment 12 Robert 'Bob' Jensen 2007-10-31 23:31:13 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=340221 is closed, the patch Warren
mentioned for F8 solved my F7 problems in 2.6.23.1-20.fc7

Note You need to log in before you can comment on or make changes to this bug.