Bug 350461 - Mailman init script prevents proper SELinux domain transitions
Mailman init script prevents proper SELinux domain transitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 09:42 EDT by Tomas Smetana
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 07:12:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Smetana 2007-10-24 09:42:30 EDT
+++ This bug was initially created as a clone of Bug #252185 +++

Description of problem:

The init script that launches mailman qrunners uses the form "interpreter
script" instead of "script" to launch the mailmanctl script. Because of this
proper SELinux domain transitions cannot occur and the Mailman qrunner ends up
in initrc_t domain.

Version-Release number of selected component (if applicable):
mailman-2.1.9-2

How reproducible:
Always

Steps to Reproduce:
1. Start mailman with SELinux in permissive mode.
2. Execute "ps xuwa -Z | grep qrunner"
  
Actual results:
The processes run in initrc_t domain.

Expected results:
The processes should run in mailman_mail_t domain.

Additional info:
A patch against the init script is attached.

-- Additional comment from aleksander.adamowski.redhat@altkom.pl on 2007-08-14
12:16 EST --
Created an attachment (id=161280)
A patch to get rid of direct interpreter invocation in mailman init script


-- Additional comment from tsmetana@redhat.com on 2007-10-23 03:58 EST --
I got some AVC messages after applying the patch.  This means that we might need
to update also the policy and need to test this for some time.  Maybe we should
start with this in Fedora first.

Note You need to log in before you can comment on or make changes to this bug.