Bug 35052 - sndconfig fails to set up ISA Creative SB16 PnP card
sndconfig fails to set up ISA Creative SB16 PnP card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 12:36 EDT by Michael Young
Modified: 2014-03-16 22:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 04:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/isapnp from M.A.Young's machine (2.92 KB, text/plain)
2001-04-23 07:03 EDT, Michael Young
no flags Details
patch for one missing SB PnP id. (904 bytes, patch)
2001-07-09 01:11 EDT, Bill Nottingham
no flags Details | Diff
patch to add *two* new SB16 ids (1.72 KB, patch)
2001-07-09 09:42 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Michael Young 2001-04-06 12:36:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

For some recent kernel versions (including 2.4.2-0.1.49) sound has failed
to work from the previously successful set up, and now if I run sndconfig
it doesn't automatically detect my card, and if I make some sensible
guesses I get kernel module errors when I try to run the first sound test. 
 My attempts to get sound working by hand have failed. For example, if I
try to load the sb module by hand with modprobe, and some sensible
settings, it fails (see below). It stops complaining if I add the module
option pnplegacy=1, though the sound still doesn't work. I am not sure
where there is a kernel problem stopping sound from working at all, or
there are some correct settings but sndconfig doesn't find them.

Reproducible: Always
Steps to Reproduce:
1.run sndconfig
2.guess some settings
3.try to play "linus" sample.
	

Some manual attempts to load the sb module:
[root@itspc116 /etc]# modprobe sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330
pnplegacy=0
sb: No ISAPnP cards found, trying standard ones...
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/sb.o: init_module: No such
device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/sb.o: insmod
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/sb.o failed
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/sb.o: insmod sb failed
[root@itspc116 /etc]# modprobe sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330
pnpl
egacy=1
sb: No legacy SoundBlaster cards found.  Continuing with PnP detection.
sb: 1 Soundblaster PnP card(s) found.
Comment 1 Bill Nottingham 2001-04-06 13:25:00 EDT
What version of sndconfig?
Comment 2 Michael Young 2001-04-06 13:52:31 EDT
I updated it via up2date this morning, so it is probably 0.64.8 , though I can't
check this until Monday morning (uk time).
Comment 3 Bill Nottingham 2001-04-08 23:58:57 EDT
What does the /etc/modules.conf that sndconfig writes look like?
Comment 4 Michael Young 2001-04-09 05:05:36 EDT
It doesn't write to /etc/modules.conf because sndconfig loops back to the start
after an errors page with errors similar to the modprobe errors above. However
the working file /etc/sndconfig-z38rIc is as follows

alias eth0 ne
options ne io=0x300
alias parport_lowlevel parport_pc
alias sound-slot-0 sb
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1
|| :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330
Comment 5 Michael Young 2001-04-20 04:37:00 EDT
The same problem exists in the release version of Redhat 7.1 (a clean install).
Comment 6 Michael Young 2001-04-20 12:11:26 EDT
Bug 36722 may be related to this bug.
Comment 7 Need Real Name 2001-04-22 18:04:40 EDT
   I'm seeing very similar behavior, and apparently have since I tried to
build/install 2.4.0 a while back.  I aborted that attempt, because of some
bizarre/unexplained drive access upon login.  I decided to just defer the kernel
upgrade until the 7.1 release.  Imagine my surprise when I observed the same
behavior after I upgraded from the 7.1 distro.  :p

   Anyway, I was able to attribute the harddrive access to repeatedly failed
"modprobe sb" commands.  I commented out all the sb-related lines in
modules.conf and restarted.  My plan was to run sndconfig w/ a clean slate to
clear up the problem.  Unfortunately, I run into what's likely the same problem
that is reported above.  Sndconfig reports:

/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: init_module: No such
device                                   
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: insmod        
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o failed         
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: insmod sound-slot-0 failed  

when trying to test my manual (noprobe) sound config that has worked for every
release up til now.  Manual attempts to install the module fail just as
described above.  Tell me how I can help expose the root cause of this critter.
:)
Comment 8 Michael Young 2001-04-23 07:03:27 EDT
Created attachment 16105 [details]
/proc/isapnp from M.A.Young's machine
Comment 9 Michael Young 2001-04-23 07:07:42 EDT
I suspect a solution along the lines of that in bug 36722 will fix the problem,
though I don't have the space on my machine to compile kernels so I can't test
this. I have attached the output from my /proc/isapnp as I suspect this will
help.
Comment 10 macgyver 2001-07-04 19:17:18 EDT
I to have the same bug, I am able to load it well ass backwards
isapnp /etc/isapnp.conf
sndconfig --quiet
this gives me some sound support but many things fail left and right
note this is a standard SB16 and worked flawlessly under 7.0
specifically its a CTL002c Serial No 486128281
any help appreciated, note stock 7.1 update all but kernal stuff via up2date, have not updated the kernal because have the ltwinmodem kernal specific patch installed I know one of these days I need to be brave chance a build and see if I can compile the winmodem patch into a newer kernal (some people say that might fix my problem) but thought I'd mention it.

Comment 11 Andre Robatino 2001-07-06 11:24:39 EDT
  I have a similar bug with an ISA PnP Crystal CS4235 sound chip.  When I run
sndconfig (either the older version with RH 7.0 or the 7.1 version), it
configures sound successfully, but MIDI fails with the message

/lib/modules/2.4.3-12/kernel/drivers/sound/opl3.o:
init_module: No such device

and then it says that insmod opl3.o failed.  This was after a clean install of
7.1 followed immediately by a kernel upgrade.  I neglected to see if it happened
with the original 2.4.2 kernel.  I also get error messages at boot time
mentioning that modules.conf has been modified more recently than modules.dep
(I'm guessing that sndconfig is responsible for trying to rewrite modules.conf)
and a similar message at shutdown.  Oddly enough, according to nm there _is_ an
init_module symbol in opl3.o.  I have APM disabled at boot time, I can't run the
2.4 kernel otherwise (see bug 39191). There are two other problems which may or
may not be related: at shutdown, there's an error message

modprobe: modprobe: can't locate module ppp0

(even though dial-up and DSL both work) and also the floppy drive doesn't work. 
The drive light doesn't even go on when I try to access it, and there's
apparently no IRQ assigned to it (maybe there's a conflict with the default
assignments that sndconfig is making, I didn't attempt to do it manually.  It
used to work automatically.).  It works in Windows 98, and it's accessed at boot
time when trying to find the boot device, so it's definitely an OS issue.
Comment 12 Andre Robatino 2001-07-06 11:39:54 EDT
  Ignore what I said about nm, I realized that the init_module message was
_from_ init_module.
Comment 13 Bill Nottingham 2001-07-09 01:10:53 EDT
The cs4232 problem is different; the (first) sb16 problem is just a missing PnP
id in the driver. (Patch attached for this.)

macgyver@imneverwrong.com: could you post your full /proc/isapnp?
Comment 14 Bill Nottingham 2001-07-09 01:11:33 EDT
Created attachment 23027 [details]
patch for one missing SB PnP id.
Comment 15 macgyver 2001-07-09 04:55:14 EDT
sure here is my full /proc/isapnp
---
Card 1 'CTL002c:Creative SB16 PnP' PnP version 1.0 Product version 1.0
  Logical device 0 'CTL0031:Audio'
    Device is active
    Active port 0x220,0x330,0x388
    Active IRQ 5 [0x2]
    Active DMA 1,5
    Resources 0
      Priority preferred
      Port 0x220-0x220, align 0x0, size 0x10, 16-bit address decoding
      Port 0x330-0x330, align 0x0, size 0x2, 16-bit address decoding
      Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
      IRQ 5 High-Edge
      DMA 1 8-bit byte-count compatible
      DMA 5 16-bit word-count compatible
      Alternate resources 0:1
        Priority acceptable
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:2
        Priority acceptable
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:3
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:4
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
      Alternate resources 0:5
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
      Alternate resources 0:6
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,10,11 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
  Logical device 1 'PNPffff:Reserved'
    Device is not active
    Resources 0
      Priority preferred
      Port 0x100-0x3f8, align 0x7, size 0x1, 16-bit address decoding
  Logical device 2 'PNPffff:Reserved'
    Device is not active
    Resources 0
      Priority preferred
      Port 0x100-0x3f8, align 0x7, size 0x1, 16-bit address decoding
  Logical device 3 'CTL7001:Game'
    Compatible device PNPb02f
    Device is not active
    Resources 0
      Priority preferred
      Port 0x200-0x200, align 0x0, size 0x8, 16-bit address decoding

----
Comment 16 Bill Nottingham 2001-07-09 09:41:59 EDT
OK, here's the updated patch that should cover that one too.
Comment 17 Bill Nottingham 2001-07-09 09:42:55 EDT
Created attachment 23068 [details]
patch to add *two* new SB16 ids
Comment 18 Michael Young 2001-07-10 04:40:55 EDT
I have applied the first patch (by compiling the modules on a separate machine)
and the new sound modules fix my problem.
Comment 19 Michael Young 2001-08-07 04:46:34 EDT
My sound card also works in roswell (upgraded from seawolf); no kernel hacking
necessary.
Comment 20 Bill Nottingham 2001-08-07 10:54:05 EDT
Marking as resolved.

Note You need to log in before you can comment on or make changes to this bug.