Bug 36722 - kernel does not find sound card/insmod sb fails
kernel does not find sound card/insmod sb fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-19 21:16 EDT by Paul Johnson
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 20:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adds another SB PnP id (494 bytes, patch)
2001-04-19 23:19 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Paul Johnson 2001-04-19 21:16:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


I have ISA PNP AWE32 card.
I did the RH7.1 install on a clean partition, on first rebood redhat
recognized a new device, and said it would configure.  Sound did not work,
however, and i tried to run /sbin/sndconfig.  That does recognize the AWE32
card, however it cannot make the sound work because the module sb cannot be
inserted. Errors like this appear in the middle of the sndconfig window.

# /sbin/modprobe sb
Note: /etc/modules.conf is more recent than
/lib/modules/2.4.2-2/modules.dep
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: insmod
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o failed
/lib/modules/2.4.2-2/kernel/drivers/sound/sb.o: insmod sb failed

I've been reading the usenet all day and found many people with problems,
but none that have explained to me what I'm supposed to do.

Reproducible: Always
Steps to Reproduce:
1. Start computer <grin>
2. /sbin/modprobe sb

	

Actual Results:  sound does not work

This is an isa AWE32 card. The 7.1 install did not install isapnptools and
I do not have /etc/isapnp.conf after the insall. I read Alan Cox's comments
in the RH list that I'm not supposed to install isapnptools to get a handle
on this.  I'm sorry to have to bother you with it, but I've tried my best.

In the /sbin/sndconfig program, I've run over and over again changing the
irq/io/dma setttings. Always the sound sample fails to play and the module
errors pop up.  

I have an IBM eepro100 ethernet card. In MS Windows, that card uses irq=11
and the sound card uses irq=5. When Linux starts, the ethernet card seems
to grab up irq=5. I thought that may be the source of the confilict, but in
Redhat 7.0 (on a separate partition) I have the ethernet card always using
irq=5 and the sound card shares an irq=7 with the printer port.


The system seems to find the card. The dmesg output has:

Activating ISA DMA hang workarounds.
isapnp: Scanning for PnP cards...
isapnp: Calling quirk for 01:00
isapnp: SB audio device quirk - increasing port range
isapnp: Calling quirk for 01:02
isapnp: AWE32 quirk - adding two ports
isapnp: Card 'Creative SB AWE32 PnP'
isapnp: 1 Plug & Play card detected total
Linux NET4.0 for Linux 2.4

But later I see this:

Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: I/O, IRQ, and DMA are mandatory
No detected device
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
ISAPnP reports AWE32 WaveTable at i/o 0x620
<SoundBlaster EMU8000 (RAM2048k)>
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
sb: dsp reset failed.




cat /proc/isapnp
# cat isapnp | more
Card 1 'CTL0047:Creative SB AWE32 PnP' PnP version 1.0 Product version 1.0
  Logical device 0 'CTL0031:Audio'
    Device is not active
    Resources 0
      Priority preferred
      Port 0x220-0x220, align 0x0, size 0x10, 16-bit address decoding
      Port 0x330-0x330, align 0x0, size 0x2, 16-bit address decoding
      Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
      IRQ 5 High-Edge
      DMA 1 8-bit byte-count compatible
      DMA 5 16-bit word-count compatible
      Alternate resources 0:1
        Priority acceptable
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:2
        Priority acceptable
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:3
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
        DMA 5,6,7 16-bit word-count compatible
      Alternate resources 0:4
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        Port 0x388-0x3f8, align 0x0, size 0x4, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
      Alternate resources 0:5
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        Port 0x300-0x330, align 0x2f, size 0x2, 16-bit address decoding
        IRQ 5,7,10 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
      Alternate resources 0:6
        Priority functional
        Port 0x220-0x280, align 0x1f, size 0x10, 16-bit address decoding
        IRQ 5,7,10,11 High-Edge
        DMA 0,1,3 8-bit byte-count compatible
Comment 1 Bill Nottingham 2001-04-19 23:18:59 EDT
Try the attached kernel patch; this should do the trick, I'd think.
Comment 2 Bill Nottingham 2001-04-19 23:19:32 EDT
Created attachment 15844 [details]
adds another SB PnP id
Comment 3 Paul Johnson 2001-04-20 01:03:46 EDT
Dear RH folk:
  Thanks for the quick response.   The guy who passes out ethernet card patches
gives a gcc command to make it go, so you don't have to rebuild the whole
kernel.

  Can you do the same for me with this patch, just to build sb.o? I've applied
it cleanly to the RedHat kernel-source that I installed, but I don't know how to
rebuild just that module. Possible?

  Otherwise, I have to download your kernel SRPM, put the patch in its spec
file, then rebuild that?
Comment 4 Arjan van de Ven 2001-04-20 04:57:57 EDT
Putting the patch in the spec file will work for sure.
but the following _might_ work:
gcc =-I/lib/modules/`uname -r`/build/include -O2 -Wall -D__KERNEL__ -DMODULE
-DMODVERSIONS -c -o sb.o sb.c 
Comment 5 Paul Johnson 2001-04-20 10:53:32 EDT
That gcc line doesn't work, so I'm rebuilding from SRPM. Is it correct to do
"rpm -bb kernel.spec --target=i686" after inserting the patch? I just wonder
because I see a lot of worrisome warnings.  If so, why are there so many warning
messages. A ton of preprocessor messages about things not giving valid
preprocessor tokens, and then ones like:
BUILDING A KERNEL FOR smp i686...
+ make -s -j 1 bzImage
{standard input}: Assembler messages:
{standard input}:814: Warning: indirect lcall without `*'

objcopy: Warning: Output file cannot represent architecture UNKNOWN!
fore200e_mkfirm.c: In function `usage':
fore200e_mkfirm.c:30: warning: implicit declaration of function `exit'
fore200e_mkfirm.c: In function `main':
fore200e_mkfirm.c:120: warning: implicit declaration of function `ctime'
fore200e_mkfirm.c:120: warning: format argument is not a pointer (arg 5)
^[[5~md5sum: WARNING: 12 of 12 computed checksums did NOT match

That last one looks especially scary.
Comment 6 Arjan van de Ven 2001-04-20 11:00:43 EDT
Yes that is what I do all the time ;)
about the warnings: I only got so much time for fixing them, and one driver
didn't make it in time for our freeze. 

"md5sum: WARNING: 12 of 12 computed checksums did NOT match"
sounds scary, but comes from the ISDN code where for certain countries the
driver has to by goverment-approved and checked by md5 sum (or similar). As soon
as 1 letter in the driver, or any of the headers, changes, the driver has to be
recertified. Certification was last done (by the ISDN folks) at 2.4.0 so....
(certification costs money)
Comment 7 Michael Young 2001-04-20 12:09:27 EDT
Bug 35052 may be related to this one.
Comment 8 Paul Johnson 2001-04-20 20:16:04 EDT
I built the kernel RPM with the new patch. It compiled with those warnings I
mentioned before, but finished up fine, and now my sound card works.  If anybody
wants a copy of that kernel.rpm, email me (pauljohn@ukans.edu)

You can close this bug report as far as I'm concerned.

I'm writing my "Ode to a RedHat Engineer" praising the speed with which you have
addressed these things. I'm amazed/delighted.
Comment 9 Arjan van de Ven 2001-04-21 05:01:15 EDT
We'll add the patch to our internal rpm so it will be in our next kernel
we release. Hence the closing as "rawhide"
Thanks for testing!

Note You need to log in before you can comment on or make changes to this bug.