Bug 35054 - Sun's Java stalls
Sun's Java stalls
Status: CLOSED DUPLICATE of bug 27090
Product: Red Hat Raw Hide
Classification: Retired
Component: basesystem (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 13:20 EDT by Vladimir Kondratiev
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 13:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kondratiev 2001-04-06 13:20:27 EDT
Component specified is wrong, but I did not found 'other' or something else
thet match.

Sun's JDK (RPM installation) jdk-1.3.0_02-fcs do not run on RawHide
installation. jdk-1.3.0 do not work as well. Sympthoms are the same,
following info related to 1.3.0_02
The same jdk works well on RH7.0 installation.
I installed RPM from Sun, set JAVA_PATH (to /usr/java/jdk1.3.0_02).
$JAVA_PATH/bin/java -version
stalls,
there are 4 threads, I investigated them with 'strace'
- one is waiting in 'exit' and is in 'zombie' state;
- one is looping issuing 'nanosleep'
(strace prints:)
nanosleep({0, 1000000}, {0, 20000000})  = 0
- one looping like:
nanosleep({0, 999858000}, NULL)         = 0
rt_sigprocmask(SIG_SETMASK, [QUIT RT_0], NULL, 8) = 0
gettimeofday({986577361, 469076}, NULL) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [QUIT RT_0], 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RT_0], [QUIT RT_0], 8) = 0
gettimeofday({986577361, 469217}, NULL) = 0
- one is sleeping in (WCHAIN) rt_sigsuspend

Since the same jdk is working on RH 7.0 and not working on RawHide, RawHide
suspected.

Details about host:
CPU PIII 866Mhz, 256Mb RAM, plenty of space on (IDE) hard drive.
Comment 1 Bill Nottingham 2001-04-06 13:23:53 EDT

*** This bug has been marked as a duplicate of 27090 ***

Note You need to log in before you can comment on or make changes to this bug.