Bug 27090 - jdk 1.3 does not start, it hanges
Summary: jdk 1.3 does not start, it hanges
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL: I have no url, just type in java --ve...
Whiteboard:
Keywords:
: 27003 28132 35054 40584 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-11 21:32 UTC by Knut J BJuland
Modified: 2016-11-24 15:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 13:55:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Knut J BJuland 2001-02-11 21:32:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-ac9 i686)


I think glibc 2.2.1 might cause problem with Suns 1.3_01 JDK installed from
rpm.

Reproducible: Always
Steps to Reproduce:
1. I just type in /usr/bin/java/jdk1.3.0_01/bin/java --version
2. Try to start mozilla with installed java plugin	
3.Or start netscape 6.0.1
	

Actual Results:  Java freezes and hang on the command line. I use bash.
Mozilla and Netscape 6 does not start.

Expected Results:  Java should have show version number and mozilla and
Netscape should have lanuched.

I use kernel 2.4.1-ac9.

Comment 1 Glen Foster 2001-02-12 23:14:49 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Jakub Jelinek 2001-02-13 12:53:12 UTC
This is a buggy JDK (it has hardcoded knowledge about thread stacks being 2MB
in size aligned to that size). We're now discussing what do with that.

Comment 3 Jakub Jelinek 2001-02-17 09:02:42 UTC
*** Bug 28132 has been marked as a duplicate of this bug. ***

Comment 4 Trond Eivind Glomsrxd 2001-02-27 02:31:00 UTC
*** Bug 27003 has been marked as a duplicate of this bug. ***

Comment 5 Trond Eivind Glomsrxd 2001-02-27 02:31:31 UTC
*** Bug 27003 has been marked as a duplicate of this bug. ***

Comment 6 Chris Chabot 2001-02-27 04:07:42 UTC
Do note that this behaviour happens with both Sun's JRE, as well as IBM's JRE.

IBM's JRE can be get work work when force-installing the i386 glibc packages
(rpm -ivh --force glibc-...-i386.rpm). This however does not fix Sun's JRE 
(which is used in netscape, and various other components)



Comment 7 Jakub Jelinek 2001-03-21 12:59:18 UTC
Please try glibc-2.2.2-7 and pass
LD_ASSUME_KERNEL=2.2.5
in environment to JRE.

Comment 8 Knut J BJuland 2001-03-21 13:55:14 UTC
Java works with glibc 2.2.2-7 and export LD_ASSUME_KERNEL=2.2.5 in
./home/user/.bashrc

Comment 9 Jakub Jelinek 2001-03-21 13:59:26 UTC
Great.
Sun is testing a JDK fix ATM AFAIK, so with next JDK it won't be necessary
to use this env variable.

Comment 10 Bill Nottingham 2001-04-06 17:23:48 UTC
*** Bug 35054 has been marked as a duplicate of this bug. ***

Comment 11 Vladimir Kondratiev 2001-04-06 18:03:28 UTC
export LD_ASSUME_KERNEL=2.2.5

is better to put in $JAVA_HOME/bin/.java_wrapper
This way it is set for Java only. Tested with appletviewer and Forte for Java.

Comment 12 Need Real Name 2001-05-03 14:46:56 UTC
Sun's jdk1.3.1rc2 works with redhat7.1

Comment 13 Trond Eivind Glomsrxd 2001-05-14 21:01:45 UTC
*** Bug 40584 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.