Bug 35080 - pdftex is compiled with wrong libpng version
Summary: pdftex is compiled with wrong libpng version
Status: CLOSED DUPLICATE of bug 19107
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-06 23:24 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 23:24:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-04-06 23:24:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18smp i686)


The /usr/bin/pdftex binary appears to be compiled with reference
to /usr/lib/libpng.so.2.1.0.6, instead of /usr/lib/libpng.so.2.1.0.8
library which is included with the standard Red Hat 7.0 distribution.


Reproducible: Always
Steps to Reproduce:
1. $ pdftex /usr/share/texmf/doc/pdftex/base/example.tex
	

Actual Results:  $ pdftex /usr/share/texmf/doc/pdftex/base/example.tex
This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
(/usr/share/texmf/doc/pdftex/base/example.tex[/usr/share/texmf/pdftex/config/pd
ftex.cfg]
Babel <v3.6Z> and hyphenation patterns for american, french, german,
ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/eplain/eplain.tex)
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex)
Underfull \vbox (badness 10000) has occurred while \output is active
[1[/usr/sh
are/texmf/dvips/config/pdftex.map]] [2]libpng error: Application must be
recompiled; version 1.0.6 was incompatible

Error: pdftex (file image.png): png_create_read_struct() failed

The "example.pdf" file was empty.  The problem persisted
even if I removed the "image.png" file that was supposed to
be included in the PDF document.

Expected Results:  $ pdftex /usr/share/texmf/doc/pdftex/base/example.tex
This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
(/usr/share/texmf/doc/pdftex/base/example.tex[/usr/share/texmf/pdftex/config/pd
ftex.cfg]
Babel <v3.6Z> and hyphenation patterns for american, french, german,
ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/eplain/eplain.tex)
(/usr/share/texmf/pdftex/plain/misc/pdfcolor.tex)
Underfull \vbox (badness 10000) has occurred while \output is active
[1[/usr/sh
are/texmf/dvips/config/pdftex.map]] [2] [3 <./image.png> <./image.png>
<./image
.png> <./image.png>] [4] [5] )
(see the transcript file for additional information)<cmr10.pfb>
Output written on example.pdf (5 pages, 332165 bytes).
Transcript written on example.log.

I was then able to succesfully open "example.pdf" and 
see the png images.

The expected results were generated by:
1. Downloading  
   ftp://ftp.rpmfind.net/linux/caldera/LTP/col/install/RPMS/
   libpng-1.0.6-1.i386.rpm
2. rpm -ivh --force libpng-1.0.6-1.i386.rpm
3. rm /usr/lib/libpng.so.2
4. ln -s /usr/lib/libpng.so.2.1.0.6 /usr/lib/libpng.so.2
Going back to the original link to /usr/lib/libpng.so.2.1.0.8
reproduces the error.  However, the real solution is to recompile
/usr/bin/pdftex so that it is compatible with the current version 
of libpng.  Also, a dependency check should be added to the 
tetex RPM for the proper version of libpng.

Comment 1 Tim Waugh 2001-04-07 09:57:46 UTC

*** This bug has been marked as a duplicate of 19107 ***


Note You need to log in before you can comment on or make changes to this bug.