Bug 35083 - OSError: [Errno 24] Too many open files: '/dev/null'
OSError: [Errno 24] Too many open files: '/dev/null'
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
: 35363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 20:34 EDT by adler
Modified: 2015-01-07 18:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 20:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description adler 2001-04-06 20:34:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25smp i686)


When running up2date on rawhide,  during the "get headers for avilable
packages" stage, I get an error saying

OSError: [Errno 24] Too many open files: '/dev/null'

and up2date freezes up.


Reproducible: Always
Steps to Reproduce:
1.run up2date
2.Click on the next button as if you are going to run up2date
3.watch up2date hang.
	

Here is the full output of the "core dump".

[root@ool-18bb788d /root]# up2date
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
  File "/usr/share/rhn/up2date/gui.py", line 250, in onStartPageNext
  File "/usr/share/rhn/up2date/up2date.py", line 1729, in
getUpdatedPackageList
  File "/usr/share/rhn/up2date/up2date.py", line 777, in getHeaders
  File "/usr/share/rhn/up2date/up2date.py", line 677, in getHeaderOffDisk
  File "/usr/share/rhn/up2date/up2date.py", line 950, in checkRpmMd5
OSError: [Errno 24] Too many open files: '/dev/null'

Also, here is the output from rpm -qa | grep up2date

[root@ool-18bb788d /root]# rpm -qa | grep up2date
up2date-gnome-2.5.1-1
up2date-2.5.1-1
Comment 1 Preston Brown 2001-04-07 11:39:15 EDT
I would imagine that this is probably happening while upgrading the "dev" 
package.  Skip that one.

Or, you can up the amount of open files in your kernel by cat'ing a larger 
number into /proc/sys/fs/file-max.
Comment 2 Preston Brown 2001-04-09 13:33:00 EDT
*** Bug 35363 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.