Bug 351091 - Updating to Firefox 2.0.0.8 breaks dependencies for Galeon
Updating to Firefox 2.0.0.8 breaks dependencies for Galeon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 14:47 EDT by Bryan Christ
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.0.3-12.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2007-10-24 14:47:38 EDT
Description of problem:

Updating Firefox 2.0.0.8 causes dependency conflict with gecko-libs.  Galeon and
Epiphany expect gecko-libs 1.8.1.5

I removed Galeon in order to update Firefox, but now Epiphany and Galeon cannot
be installed.

[root@tuxdev ~]# yum install galeon
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package galeon.i386 0:2.0.3-11.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: galeon
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.5 is needed by package galeon
[root@tuxdev ~]# yum install epiphany
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package epiphany.i386 0:2.18.3-2.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: epiphany
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.5 is needed by package epiphany

Version-Release number of selected component (if applicable):


How reproducible:

unknown

Steps to Reproduce:
1.  Update Firefox via yum (may have to remove Galeon, Epiphany, and yelp)
2.  Try to install Galeon or Epiphany via yum
3.
  
Actual results:



Expected results:


Additional info:
Comment 1 Marcel Nijenhof 2007-10-24 15:15:40 EDT
The same problem for "yelp" and "devhelp".
Comment 2 Kevin J. Cummings 2007-10-24 16:13:57 EDT
Same problem here.  Can't upgrade to firefox 2.0.0.8 because yelp and devhelp
require gecko-libs=1.8.1.5
Comment 3 Alex Lancaster 2007-10-24 21:07:46 EDT
This is a general problem with security fixes for Firefox and should be helped
once those apps can depend on xulrunner, rather than firefox.
Comment 4 Alex Lancaster 2007-10-24 21:09:47 EDT
Cc-ing Denis Leroy, maintainer of galeon, to alert him about need to rebuild
galeon ASAP.
Comment 5 Alex Lancaster 2007-10-25 02:10:51 EDT
(In reply to comment #4)
> Cc-ing Denis Leroy, maintainer of galeon, to alert him about need to rebuild
> galeon ASAP.

I took the liberty of rebuilding galeon, the koji builds are here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=22307

if you are a Fedora contributor, please visit:

https://admin.fedoraproject.org/updates/F7/pending/galeon-2.0.3-12.fc7

and please bump up the Karma points if it works for you.
Comment 6 Alex Lancaster 2007-10-25 02:13:41 EDT
Changing component to galeon as epiphany has now been rebuilt and is available
in updates:

https://admin.fedoraproject.org/updates/F7/FEDORA-2007-0820
Comment 7 Matěj Cepl 2007-10-25 04:19:54 EDT

*** This bug has been marked as a duplicate of 350811 ***
Comment 8 Alex Lancaster 2007-10-25 04:55:28 EDT
Re-open because galeon is not updates-testing as stated in bug #350811.  I have
a build of galeon pending at:
https://admin.fedoraproject.org/updates/F7/pending/Miro-0.9.8.1-4.fc7,galeon-2.0.3-12.fc7

once that is pushed to updates (aka stable), then this bug will be automatically
closed (I marked this bug in bodhi).
Comment 9 Scott Dowdle 2007-10-26 21:25:54 EDT
Just wanted to mention that the fix mentioned in bug #350811 breaks galeon and
epiphany on my system.  Not much of a fix, eh?
Comment 10 Alex Lancaster 2007-10-26 21:40:25 EDT
(In reply to comment #9)
> Just wanted to mention that the fix mentioned in bug #350811 breaks galeon and
> epiphany on my system.  Not much of a fix, eh?

Actually comment #8 in bug #350811 is actually wrong.   galeon is not yet in
updates-testing (nor in updates).  epiphany *has* been rebuilt and is available
in updates, and I rebuilt galeon against the new firefox but we're still waiting
on the powers that be to actually push the galeon update.
Comment 11 Fedora Update System 2007-10-29 15:07:24 EDT
galeon-2.0.3-12.fc7, Miro-0.9.8.1-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.