Bug 35194 - JetDirect 9100 print errors
Summary: JetDirect 9100 print errors
Status: CLOSED DUPLICATE of bug 35193
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-08 14:55 UTC by Gene Czarcinski
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-08 14:55:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2001-04-08 14:55:17 UTC
This applies to qa0404.

I originally files this bug report against kmail but have since found that
some software of mine as well as a2ps have the same problem.

My hardware is the HP JETDIRECT EX Plus box connected to an HP 4000.

When I saw that the new RedHat printconf package supported the JetDirect
interface (port 9100), I decided to use that (I previously used the ifhp
filter with JetDirect successfully).  Now the JetDirect box can also be
configured as a Unix Printer (lpd queue).

The problem is that postscript output to the printer will terminate before
printing the entire file.  If you print a short file, then nothing is
printed although something is sent to the printer.

I can get behavior with kmail, kwrite, and a2ps but not (strangely) with
either netscape or mozilla.

When using a2ps to print a README file which generates "8 pages on 4
sheets", I get the first two sheets formated properly, then the printer
seems to pause (delay a tenth of s second) and switch modes.  A single
sheet is printed with what appears to be a single line of text surrounded
by parens (postscript).  Finally, a blank sheet is "printed".

I experimented and created another queue (lp1).  This time I defined the
JEetDirect interface as a "Unix Printer" with the ip address and the queue
defined as "raw".  When I use this second queue with a2ps, kmail, kwrite,
etc. everything works!!

Since the printconf package includes the filters, etc. for printing files,
it appears that there is a bug.  Based on my experience, it is highly
repeatable.

I will attach my printcap.

Gene

Comment 1 Bill Nottingham 2001-04-09 03:51:57 UTC

*** This bug has been marked as a duplicate of 35193 ***


Note You need to log in before you can comment on or make changes to this bug.