Bug 352331 - "who -m" or "who am i" does not give any output
"who -m" or "who am i" does not give any output
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2007-10-25 10:06 EDT by Ernst-L. Petersen
Modified: 2008-02-18 09:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-18 09:35:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ernst-L. Petersen 2007-10-25 10:06:26 EDT
Description of problem:
who -m or who with two arguments does not give any output

Version-Release number of selected component (if applicable):

How reproducible:
'who -m'

Steps to Reproduce:
1. type "who -m" in konsole
2. "who am i" does not work either
Actual results:
no output

Expected results:

Additional info:
Comment 1 Ernst-L. Petersen 2007-10-25 10:08:11 EDT
Expected results:

output for who -m like explained like it worked in older versions
(who -m or who am i is also listed in who --help as a correct option)
Comment 2 Ondrej Vasik 2007-10-25 10:54:38 EDT
It works for me with RHEL5 coreutils and i386 architecture. Could you please
specify architecture on which are you running "who -m" or something specific on
the system? Can't reproduce here.
Comment 3 Ernst-L. Petersen 2007-10-25 11:17:40 EDT
it's funny, it works on gnome-terminal or console (ATL-F1) but not on konsole (KDE)?
Comment 4 Ernst-L. Petersen 2007-10-25 11:30:40 EDT
may be the same problem:
the command 'w' gives only the headline but not me as user:

[ernpeter@bbl1lel5 home]$ w
 17:29:25 up 77 days,  1:51,  1 user,  load average: 0.00, 0.01, 0.00
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
[ernpeter@bbl1lel5 home]$

Comment 5 Ondrej Vasik 2007-10-25 11:34:46 EDT
Tried with KDE konsole (in Gnome, but it IMHO doesn't matter) and is working
without troubles on my machine. Same with gnome-terminal, xterm and Linux
console(alt-f1). It seems to be something specific on your system(bad paths for
konsole, bad alias or something like that). I doubt that it is bug in coreutils.
Comment 6 Ondrej Vasik 2007-10-26 04:26:53 EDT
Adding kdebase owner to cc as konsole is part of it. Maybe he can help with this
Comment 7 Ernst-L. Petersen 2007-11-06 05:12:10 EST
What further infos can i provide for you to reproduce the problem?
Comment 8 Ondrej Vasik 2007-11-06 06:23:36 EST
Information which could be helpful:
rpm -q kdebase 
system architecture(i386/x86_64/...)
Is that reproducible on other machine you have?
Is selinux active/which mode?

For me is NOT reproducible on konsole/console/xterm/gnome-terminal with the
version of coreutils you specified and i386 architecture. My kdebase is
kdebase-3.5.7-1.fc6 (as you mentioned that the issue occured only in KDE konsole). 
I really doubt that the problem is in coreutils who ... 
Comment 9 Ernst-L. Petersen 2007-11-06 07:28:22 EST
system architecture(i386/x86_64/...)
uname -a:
Linux bbl1lel5.bbl.ms.philips.com 2.6.18-8.1.1.el5xen #1 SMP Mon Feb 26 21:05:12
EST 2007 i686 i686 i386 GNU/Linux

Is that reproducible on other machine you have?
Yes, on all RHEL5

Is selinux active/which mode?

Comment 10 Ernst-L. Petersen 2007-11-06 07:29:46 EST
rpm -q kdebase
Comment 11 Ondrej Vasik 2007-11-06 08:36:59 EST
I was able to reproduce on RHEL5 with kdebase you mentioned. With newer
konsole(kdebase) I'm not able to reproduce the bug, so I'm redirecting component
to kdebase and adding me to cc. There is high similarity to bug 235972 , which
is against FC-6 with similar versions to RHEL5.
Comment 12 Ngo Than 2008-02-18 09:35:24 EST
it's fixed in kdelibs-3.5.4-16/kdebase-3.5.4-18

Note You need to log in before you can comment on or make changes to this bug.