Bug 235972 - /usr/bin/w or /usr/bin/who does not display user logged into KDE desktop environment
/usr/bin/w or /usr/bin/who does not display user logged into KDE desktop envi...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 246064 (view as bug list)
Depends On: 246063
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 02:38 EDT by John K. McIver III
Modified: 2008-02-04 06:55 EST (History)
1 user (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 06:55:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John K. McIver III 2007-04-11 02:38:03 EDT
Description of problem:
User that is logged onto the KDE desktop environment is not listed
when issuing /usr/bin/who or /usr/bin/w.

Version-Release number of selected component (if applicable):
Updated as of 04-10-2007.

How reproducible:
Always.

Steps to Reproduce:
1. Log into KDE via GDM.
2. Open terminal (Konsole).
3. Execute /usr/bin/who or execute /usr/bin/w.

Actual results:
User logged on through the graphical environment (GDM) into KDE are
not listed in the output:

[user@host cwd]# w
 14:17:30 up 1 day, 19:00,  0 users,  load average: 0.03, 0.05, 0.01
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHA
[user@host cwd]#

Expected results:
I would expect to see the user that is logged into the KDE desktop
environment listed as a logged on user as I am used to seeing on
previous releases of FC and RHEL.

Here is what the output looks like in a Gnome desktop session running
on FC 6:

[user@host cwd]$ w
 23:55:36 up 35 min,  1 user,  load average: 0.82, 0.39, 0.20
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
user     pts/0    :0.0             23:54    0.00s  2.34s  0.01s w
[user@host cwd]$ 

Additional info:
This bug is similar in behavior to Bugzilla Bug 214130.

kdebase version    : kdebase-3.5.6-0.1.fc6
libutempter version: libutempter-1.1.4-3.fc6
Comment 1 Lukáš Tinkl 2008-01-02 09:28:54 EST
*** Bug 246064 has been marked as a duplicate of this bug. ***
Comment 2 Lukáš Tinkl 2008-01-02 09:34:24 EST
Seems the fix depends on #246063
Comment 3 Lukáš Tinkl 2008-02-04 06:55:12 EST
Fixed in F8/F7 updates

Note You need to log in before you can comment on or make changes to this bug.