Bug 352631 - Underscores in node names are accidentally trimmed in cluster.conf://failoverdomainnode/@name
Underscores in node names are accidentally trimmed in cluster.conf://failover...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
: 488191 (view as bug list)
Depends On:
Blocks: 530200
  Show dependency treegraph
 
Reported: 2007-10-25 12:22 EDT by Satoru SATOH
Modified: 2016-08-29 07:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 530200 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An experimental patch to allow underscores in cluster node names (427 bytes, patch)
2007-10-25 12:22 EDT, Satoru SATOH
no flags Details | Diff

  None (edit)
Description Satoru SATOH 2007-10-25 12:22:24 EDT
Description of problem: Underscores in node name
(cluster.conf://failoverdomainnode/@name) are accidentally trimmed
because label texts passed to gtk.MenuItem without use_underline parameter.

So if node name includes '_',  //clusternode/@name and 
//failoverdomainnode/@name in cluster.conf becomes mismatched and 
cluster should not work correctly.


Version-Release number of selected component (if applicable):
I confirmed this issue with system-config-cluster in Red Hat Cluster 
Suite 4 U5 and RHEL 5 AP.


How reproducible: always


Steps to Reproduce:
1. set node name includes '_' (underscore)
2. select that node in failover domain dialog

  
Actual results: 
'_' in node name (cluster.conf://failoverdomainnode/@name) is trimmed.


Expected results: Not trimmed.


Additional info:
I attach an experimental patch to fix this issue.
Comment 1 Satoru SATOH 2007-10-25 12:22:24 EDT
Created attachment 237551 [details]
An experimental patch to allow underscores in cluster node names
Comment 2 Satoru SATOH 2007-11-03 20:57:21 EDT
It's a evident problem of the program and easy to fix although host (node) name
should not contain '_', so I raise the level of severity and priority of this.
Comment 5 Chris Ward 2010-02-11 05:13:41 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 6 Brian Brock 2010-03-09 15:17:03 EST
fix verified in system-config-cluster-1.0.57-3, cluster.conf looks good for nodes with _ in the name.
Comment 10 errata-xmlrpc 2010-03-30 04:54:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0288.html
Comment 11 Ryan McCabe 2010-10-26 16:31:57 EDT
*** Bug 488191 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.