Bug 353081 - Java Plugin doesn't work in the browser
Java Plugin doesn't work in the browser
Status: CLOSED DUPLICATE of bug 372071
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 15:30 EDT by Prasad
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 12:25:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad 2007-10-25 15:30:21 EDT
Description of problem:

Java Plugin doesn't work in the browser.

Version-Release number of selected component (if applicable):

Firefox 2.0.0.8

java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Server VM (build 1.6.0_03-b05, mixed mode)


How reproducible:


Steps to Reproduce:
1. Download latest jre from sun website.
2. cd /usr/lib/firefox2.0.0.8/plugins/
3. ln -s <jre directory>/plugin/i386/ns7/libjavaplugin_oji.so .
4. Restart browser if it is currently running.
5. http://www.java.com/en/download/installed.jsp and click verify installation
button
  
Actual results:

JVM doesn't get launched.

Expected results:

Expected vm to start.


Additional info:

Linux octavia 2.6.23.1-31.fc8 #1 SMP Tue Oct 23 14:42:19 EDT 2007 i686 i686 i386
GNU/Linux

Contents of ~/.mozilla/firefox/pluginreg.dat file.

Generated File. Do not edit.

[HEADER]
Version:0.08:$

[PLUGINS]
/usr/lib/nspluginwrapper/npwrapper.so:$
:$
1193194970000:1:5:$
<a href="http://gwenole.beauchesne.info/projects/nspluginwrapper/">nspluginwrapp
er</a>  is a cross-platform NPAPI plugin viewer, in particular for linux/i386 pl
ugins.<br>This is <b>beta</b> software available under the terms of the GNU Gene
ral Public License.<br>:$
NPAPI Plugins Wrapper 0.9.91.5:$
1
0:unknown/mime-type:Do not open:none:$
/usr/lib/jvm/sun/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so:$
:$
1190700609000:1:1:$
Java(TM) Plug-in 1.6.0_03:$
Java(TM) Plug-in 1.6.0_03-b05:$
33
0:application/x-java-vm:Java::$
1:application/x-java-applet:Java::$
2:application/x-java-applet;version=1.1:Java::$
3:application/x-java-applet;version=1.1.1:Java::$
4:application/x-java-applet;version=1.1.2:Java::$
5:application/x-java-applet;version=1.1.3:Java::$
6:application/x-java-applet;version=1.2:Java::$
7:application/x-java-applet;version=1.2.1:Java::$
8:application/x-java-applet;version=1.2.2:Java::$
9:application/x-java-applet;version=1.3:Java::$
10:application/x-java-applet;version=1.3.1:Java::$
11:application/x-java-applet;version=1.4:Java::$
12:application/x-java-applet;version=1.4.1:Java::$
13:application/x-java-applet;version=1.4.2:Java::$
14:application/x-java-applet;version=1.5:Java::$
15:application/x-java-applet;version=1.6:Java::$
16:application/x-java-applet;jpi-version=1.6.0_03:Java::$
17:application/x-java-bean:Java::$
18:application/x-java-bean;version=1.1:Java::$
19:application/x-java-bean;version=1.1.1:Java::$
20:application/x-java-bean;version=1.1.2:Java::$
21:application/x-java-bean;version=1.1.3:Java::$
22:application/x-java-bean;version=1.2:Java::$
23:application/x-java-bean;version=1.2.1:Java::$
24:application/x-java-bean;version=1.2.2:Java::$
25:application/x-java-bean;version=1.3:Java::$
26:application/x-java-bean;version=1.3.1:Java::$
27:application/x-java-bean;version=1.4:Java::$
28:application/x-java-bean;version=1.4.1:Java::$
29:application/x-java-bean;version=1.4.2:Java::$
30:application/x-java-bean;version=1.5:Java::$
31:application/x-java-bean;version=1.6:Java::$
32:application/x-java-bean;jpi-version=1.6.0_03:Java::$

Hope this helps.
Comment 1 Martin Stransky 2007-10-29 03:18:29 EDT
Why do you install it to /usr/lib/firefox2.0.0.8/plugins/? Try
/usr/lib/mozilla/plugins, this is the supposed place for all mozilla plugins.
Comment 2 Matěj Cepl 2007-10-29 13:18:29 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 3 Prasad 2007-10-29 14:19:18 EDT
Hello,

Thanks for taking a look at this problem. Given that I am running firefox
2.0.0.8, I installed the plugin under /usr/lib/firefox2.0.0.8 directory. Having
said that I copied the same plugin under /usr/lib/mozilla/plugins/ directory and
the behavior is the same.

I will remove the plugin from firefox/plugins directory and see if the behavior
will be different.

Thanks

-- Prasad
Comment 4 Prasad 2007-10-29 15:11:31 EDT
I did one more test.

If I just have the plugin under mozilla/plugins directory, the browser is not
detecting the plugin and it is prompting me to install the missing plugin.

If I have it under firefox2.0.0.8/plugins directory, it recognizes the plugin
but fails to load and eventually the verification process fails if you use the
URL pasted in the bug.

Thanks
Comment 5 Martin Stransky 2007-10-30 09:32:56 EDT
Is there any change if you remove the nspluginwrapper package?
Comment 6 Prasad 2007-10-31 17:30:08 EDT
There is no nspluginwrapper installed. As my work is getting blocked by this bug
and another, I wiped FC8 and installed Ubuntu. I won't be of much help going
forward.
Comment 7 Radek Bíba 2007-11-10 12:25:02 EST

*** This bug has been marked as a duplicate of 372071 ***

Note You need to log in before you can comment on or make changes to this bug.