Bug 372071 - Sun Java Swing Application not worked
Sun Java Swing Application not worked
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 353081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 22:00 EST by Igor A Tarasov
Modified: 2014-06-18 05:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 19:46:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor A Tarasov 2007-11-08 22:00:18 EST
Description of problem:

I'm using Sun Java and Fedora 8 release:

[root@linux fedora]# rpm -q jdk
jdk-1.6.0_03-fcs
[root@linux fedora]# java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Server VM (build 1.6.0_03-b05, mixed mode)
[root@linux fedora]# rpm -q libX11
libX11-1.1.3-4.fc8

And no one Swing application work:
[root@linux fedora]# jconsole
jconsole: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Emergency stopped

Workaround is to rollback libX11 to package from Fedora 7 :
[root@linux !backup]# rpm -U --force libX11-1.0.3-8.fc7.i386.rpm

And all working fine again.
Please, fix the bug in libX11.
Comment 1 Radek Bíba 2007-11-10 12:24:48 EST
This bug also makes the Sun Java plug-in in F8 Firefox unusable. See e.g.
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373 or bug 353081, which
I'm going to close a dupe of this one too.
Comment 2 Radek Bíba 2007-11-10 12:25:03 EST
*** Bug 353081 has been marked as a duplicate of this bug. ***
Comment 3 Luigi Tarenga 2007-11-11 13:44:51 EST
instead of forcing the installaztion of the libX11 i prefer another
workaround.

install java in /opt/java from the .bin distribution then execute:

[root@bug1 java]# /opt/java/jdk1.5.0_12/bin/jconsole 
jconsole: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted
(here you hit the bug...)

[root@bug1 java]# find /opt/java/jdk1.5.0_12/ -name lib\*awt\* -exec grep
XINERAMA \{\}  \; | while read a b c d ; do  sed -i 's/XINERAMA/FAKEEXTN/g' $c ;
done
(here you fix it, note: this is a workaround)

[root@bug1 java]# /opt/java/jdk1.5.0_12/bin/jconsole

and now it works :)

i hope that the future java 7 will work by default.
Comment 4 Luis Felipe Marzagao 2007-11-12 21:06:00 EST
Same problem here:

[duli@localhost ~]# yum list | grep -i libx11
libX11.i386                              1.1.3-4.fc8            installed 

[duli@localhost ~]$ java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

This command line fixed the issue for me:

[root@localhost ~]# sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/java/jre1.6.0_03/lib/i386/xawt/libmawt.so

Thanks.
Comment 5 Aaron Hagopian 2007-11-26 10:48:22 EST
Same problem for me too.  This is really annoying because the sed fix makes all
java swing apps totally unaware of my multiple monitors.

Please give this issue some attention.

I would use icedtea but it does not work properly with netbeans.
Comment 6 Matěj Cepl 2008-01-23 19:46:04 EST

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.