Bug 353421 - license - compatibility
Summary: license - compatibility
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 353431 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-26 01:07 UTC by shrek-m
Modified: 2009-01-08 13:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-08 13:23:55 UTC


Attachments (Terms of Use)

Description shrek-m 2007-10-26 01:07:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071023 Fedora/2.0.0.8-1.fc8 Firefox/2.0.0.8

Description of problem:
is it possible to check via the rpm-license-tag and the package-dependencies if there are license incompatibilities?
eg. GPLv3+ vs. GPLv2only

i am not sure if all %{license} are proper filed,
some licenses are listed as "distributable, freeware, public domain, gpl, lgpl, ..." instead the correct version.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. repoquery -a --qf "%{name} -- %{license}\n"

Actual Results:


Expected Results:
# rpm -q --checklicensecomp packageA packagB
  license conflict GPLv3+ GPLv2only

Additional info:
the license tag should be filed correctly in the near future.

more GPLv3+
http://gplv3.fsf.org/rms_gplv3_launch_transcript

Comment 1 Panu Matilainen 2007-10-30 18:48:03 UTC
*** Bug 353431 has been marked as a duplicate of this bug. ***

Comment 2 Bug Zapper 2008-05-14 03:44:43 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Panu Matilainen 2009-01-08 13:23:55 UTC
On rpm level, the license is just an arbitrary string. Distributions can of course mandate certain values by policy, but that's outside rpm scope. Not to mention maintaining a license-compatibility matrix and attempting to check for license compatibility - that's a job for lawyers, not rpm.

For distro-level license sanity checking helper tool, you'll be far better off looking at licenses from repository metadata.


Note You need to log in before you can comment on or make changes to this bug.