Bug 353431 - license - compatibility
license - compatibility
Status: CLOSED DUPLICATE of bug 353421
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 21:12 EDT by shrek-m
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 14:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2007-10-25 21:12:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.8) Gecko/20071023 Fedora/2.0.0.8-1.fc8 Firefox/2.0.0.8

Description of problem:
is it possible to check via the rpm-license-tag and the package-dependencies if there are license incompatibilities?
eg. GPLv3+ vs. GPLv2only

i am not sure if all %{license} are proper filed,
some licenses are listed as "distributable, freeware, public domain, gpl, lgpl, ..." instead the correct version.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. repoquery -a --qf "%{name} -- %{license}\n"

Actual Results:


Expected Results:
# rpm -q --checklicensecomp packageA packagB
  license conflict GPLv3+ GPLv2only

Additional info:
the license tag should be filed correctly in the near future.

more GPLv3+
http://gplv3.fsf.org/rms_gplv3_launch_transcript
Comment 1 Panu Matilainen 2007-10-30 14:48:02 EDT

*** This bug has been marked as a duplicate of 353421 ***

Note You need to log in before you can comment on or make changes to this bug.