Bug 353471 - kmail won't display mail text
kmail won't display mail text
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 21:54 EDT by Steve Grubb
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.5.8-10.svn20071129.ent.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 15:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump (3.62 KB, text/plain)
2007-10-25 21:58 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2007-10-25 21:54:02 EDT
Description of problem:
After looking at an email. kmail loses the text of the email and you cannot see
it ever again. I've looked at several emails, shutdown kmail, restarted it and
now there is no text. Nothing but white screen. I tried clicking on reply to see
if the text was in a buffer that would show up as quoted text. Nope. its gone.

Version-Release number of selected component (if applicable):
kdepim-3.5.8-1.svn20071013.ent.fc8
Comment 1 Steve Grubb 2007-10-25 21:58:26 EDT
Created attachment 238211 [details]
crash dump

After clicking around on a few more emails, kmail crashed. This is the dump
that it created.
Comment 2 Rex Dieter 2007-10-26 07:38:17 EDT
Please report upstream to http://bugs.kde.org/ so upstream developers are aware
of this.
Comment 3 Steve Grubb 2007-10-26 08:31:58 EDT
From the web site: The account will be created, and its password will be mailed
to you. kmail is broken in both rawhide and F7. I can't use either. I'm still
unhappy that a completely broken kmail got pushed into the stable F7 branch and
it does something that reverting cannot even fix.
Comment 4 Rex Dieter 2007-10-26 08:39:51 EDT
I can sympathize with your frustration, but...

Fact is, kmail is not "completely broken", it works well/fine for a great many
folks, including myself.  For f7, it was in updates-testing for quite awhile,
and we received nothing but positive feedback.

Now, could you perhaps provide a few details on how you have kmail setup,
account types, etc... so that we can at least try to reproduce?
Comment 5 Steve Grubb 2007-10-26 08:56:58 EDT
Sure I use an imaps account - ssl not tls, my machine is x86_64, the imap server
has at least 25,000 emails in the inbox folder, I use a filter to move all of
fedora-devel-list to a local folder. What else do you need to know? 
Comment 6 Kevin Kofler 2007-10-26 09:00:42 EDT
The kdepim-*.ent.* builds were pushed because they fix a serious KMail 
regression (IMAP filtering not working at all) in 3.5.7 (see bug 244930) and 
there was no negative feedback when they were pushed.
Comment 7 Rex Dieter 2007-10-26 09:05:38 EDT
Interesting, I'm starting to see a trend, all the reporters of problems 
recently are on x86_64.  I'll go find a x86_64 box, and do some testing 
myself...
Comment 8 Steve Grubb 2007-10-26 09:19:44 EDT
One of the thing I worry about with kde is that because its C++, you have to
watch the headers of all packages. If they change, everything that depends on
them has to be recompiled. I've seen qt change without kdelibs or base rolled
out, and kdelibs and base change without everything else being rolled out. Is it
standard practice to watch the headers for all the kde packagers?
Comment 9 Rex Dieter 2007-10-26 09:48:11 EDT
Upstream kde is very aware and diligent when it comes to maintaining abi.
Comment 10 Rex Dieter 2007-11-29 19:54:05 EST
Can you try out this test (F8) build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26132
Comment 11 Fedora Update System 2007-12-03 00:35:04 EST
kdepim-3.5.8-10.svn20071129.ent.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim'
Comment 12 Fedora Update System 2007-12-12 15:02:40 EST
kdepim-3.5.8-10.svn20071129.ent.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.