Bug 35396 - /etc/rc.d/rc.sysinit complains on directories in /var/run/mon
/etc/rc.d/rc.sysinit complains on directories in /var/run/mon
Status: CLOSED DUPLICATE of bug 26294
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-09 19:26 EDT by Jim Wright
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-09 19:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Wright 2001-04-09 19:26:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14jrw i686)


I just used up2date to bring my 7.0 system in line.  I don't know what was
there before, but now the directory /var/run/mon contains two
subdirectories.  In /etc/rc.d/rc.sysinit, it has code to clean everything
out of /var/run, along with special case code to deal with /var/run/news
and /var/run/sudo.  When booting, I get two lines of error message about rm
not being able to delete the directories /var/run/mon/log.d and
/var/run/mon/state.d.

The bug is that /etc/rc.d/rc.sysinit assumes that directories in /var/run
will not have any subdirectories.


Reproducible: Always
Steps to Reproduce:
1. reboot	

Actual Results:  error message during boot

Expected Results:  nice clean boot

% rpm -qf /etc/rc.d/rc.sysinit /var/run/mon/log.d
initscripts-5.49-1
mon-0.38.18-10

section of /etc/rc.d/rc.sysinit:

# Clean up /var
# I'd use find, but /usr may not be mounted.
for afile in /var/lock/* /var/run/*; do
   if [ -d "$afile" ]; then
      [ "`basename $afile`" != "news" -a "`basename $afile`" != "sudo" ] &&
rm -f $afile/*
   else
      rm -f $afile
   fi
done
Comment 1 Bill Nottingham 2001-04-09 21:46:08 EDT

*** This bug has been marked as a duplicate of 26294 ***

Note You need to log in before you can comment on or make changes to this bug.