Bug 353961 - lokkit doesn't write iptables config with --nostart
Summary: lokkit doesn't write iptables config with --nostart
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-firewall   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 352141 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-10-26 12:30 UTC by Mark McLoughlin
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 18:36:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2007-10-26 12:30:21 UTC
(With system-config-firewall-tui-1.0.8-1.fc8)

Running e.g.:

  $> lokkit -f --quiet --enabled --nostart --port=22:tcp

does not cause /etc/sysconfig/iptables and /etc/sysconfig/ip6tables to be
written ... only /etc/sysconfig/system-config-firewall is written.

I've noticed this under two circumstances:

  1) Installed an F8 system using anaconda over a serial console and vnc.
     When the tui firstboot ran, I just closed it. Later on I see iptables
     is running, but no rules and default policy of ACCEPT.

  2) Installed an F8 livecd and ran lokkit in %post to add some ports. When
     I ran the image there was no firewall.

Seems to me that the behavioral change of lokkit --nostart is the issue.

Comment 1 Jeremy Katz 2007-10-26 12:41:17 UTC
*** Bug 352141 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2007-10-27 03:30:14 UTC
This was built as 1.0.8-3.fc8.

Comment 3 Jeremy Katz 2007-10-28 18:36:36 UTC
Confirmed with live image of today's rawhide.


Note You need to log in before you can comment on or make changes to this bug.