Bug 35493 - gimp-remote not installed
gimp-remote not installed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
: 74888 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 16:32 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 19:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-10 16:32:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


No gimp packages contain the gimp-remote program documented in the gimp
manuals.

Reproducible: Always
Steps to Reproduce:
1. install all gimp-*.rpm packages
2. $ gimp-remote
3. $ locate gimp-remote
4. $ find / -name gimp-remote

You get the idea.
	

Actual Results:  bash: gimp-remote: command not found

and so forth.

Expected Results:  gimp-remote should have run.

For those not familiar with gimp-remote, it allows you to automate the
process of opening an image in an already running gimp process.  For
example, I set the following:

alias gimp='gimp-remote -n'

Which prevents me from getting 5 or 10 memory-hogging copies of The Gimp
each time I decide I want to edit a new image.  It's also handy to use from
programs like GQView.
Comment 1 Darin Adler 2001-04-26 13:51:58 EDT
The Ximian folks have fixed this in their version of the gimp package. See 
http://bugzilla.ximian.com/show_bug.cgi?id=2120 for the details.

Nautilus's entry for the Gimp should be using gimp-remote too, but it 
won't until this problem is resolved. See http://bugzilla.eazel.com/
show_bug.cgi?id=8162 for the details.
Comment 2 Need Real Name 2001-10-07 06:10:03 EDT
The gnome-vfs bug that Darin mentioned is now
http://bugzilla.gnome.org/show_bug.cgi?id=48162

Is anyone working on adding gimp-remote to the Red Hat gimp packages? It seems
like it should be a trivial fix.
Comment 3 Need Real Name 2002-12-10 00:04:35 EST
at first i was going to post my own bug, because i could not see this one: i
only did a bug search for versions 7.3 and 8.0... now i see it but this bug was
opened in april of 2001 for rh7.0? i am now running rh8.0 in december of 2002 --
20 months later -- and latest gimp rpm (gimp-1.2.3-9) still does not include
gimp-remote and bug is still marked (NEW(?

i tried just going ahead and downloading the tarball and compiling my own
gimp-remote executable for now (sort of defeats the purpose of rpms tho4..) but
got stuck when gcc couldn4t find jpeglib.h for xjpeg (even though configure said
it would not try to compile this part).. *sigh*

does anyone know why this taking so long to fix?

or other ways to solve the problem (like where one could get a compiled (for
rh8.0) gimp-remote?

thanks!
Comment 4 Adam Spiers 2003-05-06 15:57:37 EDT
Incredibly, this isn't fixed in RedHat 9 either.
Matt, are you still alive?  This bug is over 2
years old, and yet so trivial to fix!
Comment 5 Matt Wilson 2003-05-06 16:02:48 EDT
yes, I apologize
Comment 6 Matt Wilson 2003-10-09 19:04:32 EDT
*** Bug 74888 has been marked as a duplicate of this bug. ***
Comment 7 Matt Wilson 2003-10-09 19:06:22 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.